Ask Your Question
0

Cannot get ip from DHCP server

asked 2013-06-25 12:32:30 -0500

nour-nakouzi gravatar image

Hello,

I created two networks a public and a private network. Here's my conf:

CONTROLLER_HOST=172.25.193.119 PUBLIC_INTERFACE=eth0 PUBLIC_NETWORK=172.25.193.64/26 PUBLIC_GATEWAY=172.25.193.126 FLOATING_RANGE_START=172.25.193.108 FLOATING_RANGE_END=172.25.193.111 PUBLIC_IP=172.25.193.120 PRIVATE_INTERFACE=eth1 PRIVATE_VLAN_START=1100 PRIVATE_VLAN_END=1109 ZONE=lannion

quantum net-create priv1 --provider:physical_network private --provider:network_type vlan --provider:segmentation_id $PRIVATE_VLAN_START quantum subnet-create --name priv1_sub priv1 $PRIVATE_NETWORK

quantum router-create router1 quantum router-interface-add router1 priv1_sub quantum net-create ext --provider:network_type flat --provider:physical_network public --router:external True quantum subnet-create --name ext_sub ext $PUBLIC_NETWORK --allocation_pools type=dict list=true start=$FLOATING_RANGE_START,end=$FLOATING_RANGE_END --enable_dhcp False --gateway_ip $PUBLIC_GATEWAY check_error_code "Quantum: can't create external subnet" quantum router-gateway-set router1 ext

After creating all the components, the VM instances cannet get an IP from DHCP,

I have a network node, controller node and a compute node Any ideas

Thanks for helping me

edit retag flag offensive close merge delete

6 answers

Sort by ยป oldest newest most voted
0

answered 2013-06-28 08:33:45 -0500

nour-nakouzi gravatar image

HI! Thanks for your help, actually i found the problem, since i am running openstack on Vsphere client, i have to enable the vlan on my virtual switchs, that run ly private networks.

:)

edit flag offensive delete link more
0

answered 2013-06-25 12:40:14 -0500

nour-nakouzi gravatar image

I am using the linux bridge plugin

edit flag offensive delete link more
0

answered 2013-06-25 13:21:19 -0500

nour-nakouzi gravatar image

I want to add, that after installing the l3-agent on network node, i cannot ping any of the interfaces eth0 or eth1, and i dont know why

edit flag offensive delete link more
0

answered 2013-06-25 13:06:35 -0500

salvatore-orlando gravatar image

Hi,

Can you see the dhcp port in port-list? If not, then you should check if the dhcp agent is properly running and connected.

Otherwise, how is your 'private' network mapped in configuration files? All the mappings should refer to some bridge which is then connected to a phys int.

If you could post your whole conf files as well as brctl output that would be helpful.

Thanks for submitting this question. Il giorno 25/giu/2013 13:43, "NAKKOUZI" < question231347@answers.launchpad.net > ha scritto:

New question #231347 on quantum: https://answers.launchpad.net/quantum/+question/231347 (https://answers.launchpad.net/quantum...)

Hello,

I created two networks a public and a private network. Here's my conf:

CONTROLLER_HOST=172.25.193.119 PUBLIC_INTERFACE=eth0 PUBLIC_NETWORK=172.25.193.64/26 PUBLIC_GATEWAY=172.25.193.126 FLOATING_RANGE_START=172.25.193.108 FLOATING_RANGE_END=172.25.193.111 PUBLIC_IP=172.25.193.120 PRIVATE_INTERFACE=eth1 PRIVATE_VLAN_START=1100 PRIVATE_VLAN_END=1109 ZONE=lannion

quantum net-create priv1 --provider:physical_network private --provider:network_type vlan --provider:segmentation_id $PRIVATE_VLAN_START quantum subnet-create --name priv1_sub priv1 $PRIVATE_NETWORK

quantum router-create router1 quantum router-interface-add router1 priv1_sub quantum net-create ext --provider:network_type flat --provider:physical_network public --router:external True quantum subnet-create --name ext_sub ext $PUBLIC_NETWORK --allocation_pools type=dict list=true start=$FLOATING_RANGE_START,end=$FLOATING_RANGE_END --enable_dhcp False --gateway_ip $PUBLIC_GATEWAY check_error_code "Quantum: can't create external subnet" quantum router-gateway-set router1 ext

After creating all the components, the VM instances cannet get an IP from DHCP,

I have a network node, controller node and a compute node Any ideas

Thanks for helping me


You received this question notification because you are a member of Netstack Core Developers, which is an answer contact for quantum.

edit flag offensive delete link more
0

answered 2013-06-25 13:18:29 -0500

nour-nakouzi gravatar image

I- brctl show on Network-node bridge name bridge id STP enabled interfaces brqad38ddb5-1c 8000.000c29755f54 no eth1.1100 tap58432ed9-54 tape8988fcc-5b brqb39b6565-48 8000.000c29755f4a no eth0 tap688a3fb6-dd

brctl show on Compute-node bridge name bridge id STP enabled interfaces brqad38ddb5-1c 8000.000c29a9bc88 no eth1.1100 tapb844824e-68 ############################################################### II- My conf files on Network node vi /etc/quantum/l3_agent.ini :

[DEFAULT] interface_driver = quantum.agent.linux.interface.BridgeInterfaceDriver auth_url = http://172.25.193.119:35357/v2.0/ auth_region = RegionOne admin_tenant_name = service admin_user = quantum admin_password = servicepass use_namespaces = False external_network_bridge = router_id = a8bc5bdb-f938-4f00-b4f3-af074f751d9b gateway_external_network_id = b39b6565-4898-4b22-bf05-bb87db99d9cd


vi /etc/quantum/plugins/linuxbridge/linuxbridge_conf.ini enant_network_type = vlan network_vlan_ranges = private:1100:1109,public sql_connection = mysql://quantum:quantum@172.25.193.119/quantum physical_interface_mappings = private:eth1,public:eth0


#############################################

III- yeah i found my dhcp in port-list, it has the 10.4.2.3 IP address

edit flag offensive delete link more
0

answered 2013-06-27 04:05:22 -0500

xianghui gravatar image

hi, Suggest turn off firewall on all nodes first and then have a try. Stop service quantum-l3-agent if you use a RHEL OS and put quantum-l3-agent and quantum-dhcp-agent together, because RHEL has a limitation now, then restart quantum-dhcp-agent. Make sure dhcp interface->linux-bridge->ethernet works well both on network node and compute node. If not, show these detail information. The "pri" network you created is a typer of vlan, which needs the physical layer support the specified "segmentation_id" when you use multi-nodes.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-06-25 12:32:30 -0500

Seen: 112 times

Last updated: Jun 28 '13