quantum in openstack

asked 2013-03-20 05:49:20 -0500

msarma00 gravatar image

Hi, I installed openstack from the following tutorial:- http://devstack.org/guides/single-vm.html (http://devstack.org/guides/single-vm....)

But Quantum did not get installed because after running ./stack.sh i got the following :-

             #Whether or not quantum is expected to be available
              quantum_available=false

Can anyone please help me with this? Should i change my localrc settings and run ./stack.sh again? And if yes, do i need need to run stack.sh this time with internet connectivity?

This was my localrc:- ADMIN_PASSWORD=password MYSQL_PASSWORD=password RABBIT_PASSWORD=password SERVICE_PASSWORD=password SERVICE_TOKEN=tokentoken

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2013-03-21 04:55:36 -0500

msarma00 gravatar image

Thanks Jason, that solved my question.

edit flag offensive delete link more
0

answered 2013-03-20 06:11:00 -0500

msarma00 gravatar image

I have the following services running :-

nova, s3, glance, cinder, ec2, keystone.

edit flag offensive delete link more
0

answered 2013-03-20 13:04:29 -0500

zzs gravatar image

I think you need add the following in you localrc,

disable_service n-net enable_service q-svc enable_service q-agt enable_service q-dhcp enable_service q-l3 enable_service q-meta enable_service quantum

then rerun the ./stack.sh

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-03-20 05:49:20 -0500

Seen: 47 times

Last updated: Mar 21 '13