Ask Your Question

swauth-prep returning "Auth subsystem prep failed: 500 Server Error"

asked 2012-01-20 18:55:01 -0500

akapadia-usa gravatar image

Any idea what's going on here? Details below. Thanks.

The proxy-server.conf file is as follows. The swift version number is 1.4.5. This worked without any problems previously.

/etc/swift/proxy-server.conf :::::::::::::: [DEFAULT] bind_port = 443 cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key workers = 8 user = swift log_name = swift log_facility = LOG_LOCAL1 log_level = DEBUG

[pipeline:main] pipeline = healthcheck cache swauth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true set log_name = proxy-server set log_facility = LOG_LOCAL0 set log_level = DEBUG set access_log_name = proxy-server set access_log_facility = LOG_LOCAL0 set access_log_level = DEBUG

[filter:swauth] use = egg:swauth#swauth set log_name = swauth super_admin_key = swauthkey default_swift_cluster = cluster_name# set log_name = auth-server set log_facility = LOG_LOCAL1 set log_level = DEBUG

[filter:healthcheck] use = egg:swift#healthcheck

[filter:cache] use = egg:swift#memcache

memcache_servers =

Running the command: sudo swauth-prep -K swauthkey -A

Returns: Auth subsystem prep failed: 500 Server Error

For some reason there are no proxy-server etc. specific logs in /var/log. But syslog has the following entry:

=== Jan 20 10:38:04 load11 proxy-server Account PUT returning 503 for (503, 503, 503) (txn: txabf9975421b64e6f9697300039091983) Jan 20 10:38:04 load11 proxy-server - - 20/Jan/2012/18/38/04 PUT /v1/AUTH_.auth HTTP/1.0 503 - Swauth - - - - txabf9975421b64e6f9697300039091983 - 0.0140

Jan 20 10:38:04 load11 proxy-server STDOUT: EXCEPTION IN handle: Traceback (most recent call last): File "/usr/lib/pymodules/python2.6/swauth/", line 401, in handle return self.handle_request(req)(env, start_response) File "/usr/lib/pymodules/python2.6/swauth/", line 466, in handle_request req.response = handler(req) File "/usr/lib/pymodules/python2.6/swauth/", line 485, in handle_prep (path, resp.status)) Exception: Could not create the main auth account: /v1/AUTH_.auth 503 Internal Server Error : {'SCRIPT_NAME': '/auth/v2', 'webob.adhoc_attrs': {'start_time': 1327084684.5982449, 'bytes_transferred': '-', 'client_disconnect': False}, 'REQUEST_METHOD': 'POST', 'PATH_INFO': '/.prep', 'SERVER_PROTOCOL': 'HTTP/1.0', 'QUERY_STRING': '', 'eventlet.posthooks': [(<bound method="" swauth.posthooklogger="" of="" <swauth.middleware.swauth="" object="" at="" 0x123c4d0="">>, (<request at="" 0x14f8710="" post="" https:="""" auth="" v2="" .prep="">,), {})], 'SERVER_NAME': '', 'REMOTE_ADDR': '', 'eventlet.input': <eventlet.wsgi.input object="" at="" 0x14e38d0="">, 'HTTP_X_AUTH_ADMIN_KEY': 'swauthkey', 'wsgi.url_scheme': 'https', 'SERVER_PORT': '443', 'HTTP_X_AUTH_ADMIN_USER': '.super_admin', 'HTTP_X_CF_TRANS_ID': 'tx76452bf2-4e35-4f78-a917-7ec3a6f4ee4c', 'wsgi.input': <eventlet.wsgi.input object="" at="" 0x14e38d0="">, 'HTTP_HOST': '', 'swift.cache': <swift.common.memcached.memcachering object="" at="" 0x14f8610="">, 'HTTPS': 'on', 'wsgi.multithread': True, 'wsgi.version': (1, 0), 'GATEWAY_INTERFACE': 'CGI/1.1', 'wsgi.run_once': False, 'wsgi.errors': <swift.common.utils.loggerfileobject object="" at="" 0x1212a50="">, 'wsgi.multiprocess': False, 'CONTENT_TYPE': None, 'HTTP_ACCEPT_ENCODING': 'identity'}

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2012-01-21 01:03:42 -0500

akapadia-usa gravatar image

The device name when defining a ring was swift_objects. When I changed it to sdf1 it worked. Thanks.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2012-01-20 18:55:01 -0500

Seen: 111 times

Last updated: Jan 21 '12