Ask Your Question
0

Not supporting 'security-group' extension-alias causing tempest quotas and ext_list tests

asked 2014-01-17 14:12:29 -0500

Hi all,

We are writing a neutron plugin in which security groups support is not there, we want to use nova security groups instead. So we dont have "security-group" in supported_extension_aliases.

Now, when i am running some tempest tests, we are seeing issues because of this. For example, 1) nosetests -sv tempest.api.network.test_extensions:ExtensionsTestXML.test_list_show_extensions ==> Traceback (most recent call last): File "/opt/stack/tempest/tempest/api/network/test_extensions.py", line 77, in test_list_show_extensions self.assertIn(e, actual_alias) File "/usr/local/lib/python2.7/dist-packages/testtools/testcase.py", line 330, in assertIn self.assertThat(haystack, Contains(needle)) File "/usr/local/lib/python2.7/dist-packages/testtools/testcase.py", line 414, in assertThat raise MismatchError(matchee, matcher, mismatch, verbose) MismatchError: 'security-group' not in [u'service-type', u'ext-gw-mode', u'l3_agent_scheduler', u'lbaas_agent_scheduler', u'provider', u'binding', u'quotas', u'agent', u'metering', u'dhcp_agent_scheduler', u'external-net', u'router', u'allowed-address-pairs', u'extra_dhcp_opt', u'lbaas', u'extraroute']

2) tempest.api.network.test_quotas:QuotasTest.test_quotas​ ==> Traceback (most recent call last): File "/opt/stack/tempest/tempest/api/network/test_quotas.py", line 68, in test_quotas **new_quotas) File "/opt/stack/tempest/tempest/services/network/json/network_client.py", line 101, in update_quotas resp, body = self.put(uri, body) File "/opt/stack/tempest/tempest/services/network/network_client_base.py", line 65, in put return self.rest_client.put(uri, body, headers) File "/opt/stack/tempest/tempest/common/rest_client.py", line 314, in put return self.request('PUT', url, headers, body) File "/opt/stack/tempest/tempest/common/rest_client.py", line 436, in request resp, resp_body) File "/opt/stack/tempest/tempest/common/rest_client.py", line 486, in _error_checker raise exceptions.BadRequest(resp_body) BadRequest: Bad request Details: {u'NeutronError': u"Unrecognized attribute(s) 'security_group'"}

Why is this happening, is it a bug or am I missing somewhere. Please help me regarding this. Any help! Thank you in advance.

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2014-01-17 19:05:31 -0500

Noticed this issue as well, I have create a bug on the tempest side for this: https://bugs.launchpad.net/tempest/+bug/1270244 (https://bugs.launchpad.net/tempest/+b...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-01-17 14:12:29 -0500

Seen: 166 times

Last updated: Jan 17 '14