Ask Your Question
0

devstack errors saying stack.sh:698 nova-api did not start

asked 2013-08-06 08:56:34 -0500

harish-iyer57 gravatar image

Hi,

I tried to install openstack through devstack. Instructions followed are as per those given on devstack website i.e cloning the git repository, building localrc file and then run ./stack.sh.

After some time, i get the following error message:


echo 'stuff "cd /opt/stack/nova && /usr/local/bin/nova-api + [[ True = \T\r\u\e ]] + screen -S stack -X screen -t n-api + [[ -n /opt/stack/logs/screen ]] + screen -S stack -p n-api -X logfile /opt/stack/logs/screen/screen-n-api.2013-08-06-014852.log + screen -S stack -p n-api -X log on + ln -sf /opt/stack/logs/screen/screen-n-api.2013-08-06-014852.log /opt/stack/logs/screen/screen-n-api.log + sleep 1.5 ++ echo -ne '\015' + NL=$'\r' ' screen -S stack -p n-api -X stuff 'cd /opt/stack/nova && /usr/local/bin/nova-api || touch "/opt/stack/status/stack/n-api.failure" + echo 'Waiting for nova-api to start...' Waiting for nova-api to start... + wait_for_service 60 http://10.0.2.15:8774 + local timeout=60 + local url=http://10.0.2.15:8774 + timeout 60 sh -c 'while ! http_proxy= https_proxy= curl -s http://10.0.2.15:8774 >/dev/null; do sleep 1; done' + die 698 'nova-api did not start' + local exitcode=0 + set +o xtrace [ERROR] stack.sh:698 nova-api did not start


Any idea. I found similar issue has been reported but no solution has been given. The devstack code is uptodate with git repository.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-08-10 03:03:35 -0500

pcm gravatar image

First place to start with these types of issues is to look at the log file generated. In your case, look at /opt/stack/logs/screen/screen-n-api.log and include any error information here. That'll help narrow down the issue.

Also, include the localrc you're using.

edit flag offensive delete link more
0

answered 2013-08-12 13:21:29 -0500

hi harishiyer:

I just solved the same question.You can do like this:

when you do /usr/local/bin/nova-api it echo that: deprecated_opts=[cfg.DeprecatedOpt('sql_connection', AttributeError: 'module' object has no attribute 'DeprecatedOpt'

try to remove your current oslo module in system and then install: http://tarballs.openstack.org/oslo.config/oslo.config-1.2.0a2.tar.gz#egg=oslo.config-1.2.0a2 (http://tarballs.openstack.org/oslo.co...) . For example: cd /usr/local/lib/python2.7/dist-packages/ rm -rf oslo pip install http://tarballs.openstack.org/oslo.config/oslo.config-1.2.0a2.tar.gz#egg=oslo.config-1.2.0a2 (http://tarballs.openstack.org/oslo.co...)

then it solved!!!

liuyanstar from China

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-06 08:56:34 -0500

Seen: 670 times

Last updated: Aug 12 '13