Ask Your Question
0

./stack .sh Failed due to Permission denied

asked 2014-02-13 11:49:56 -0500

balachandar-raju gravatar image

updated 2014-12-31 12:33:35 -0500

smaffulli gravatar image
2014-02-13 17:06:35 stack.sh log /opt/stack/logs/stack.sh.log.2014-02-13-170635
2014-02-13 17:06:35 + echo_summary 'Installing package prerequisites'
2014-02-13 17:06:35 + [[ -t 3 ]]
2014-02-13 17:06:35 + [[ True != \T\r\u\e ]]
2014-02-13 17:06:35 + echo -e Installing package prerequisites
2014-02-13 17:06:35 + source /home/ubuntuserver/devstack/tools/install_prereqs.sh
2014-02-13 17:06:35 Installing package prerequisites
2014-02-13 17:06:35 ++ [[ -n '' ]]
2014-02-13 17:06:35 ++ [[ -z /home/ubuntuserver/devstack ]]
2014-02-13 17:06:35 ++ PREREQ_RERUN_MARKER=/home/ubuntuserver/devstack/.prereqs
2014-02-13 17:06:35 ++ PREREQ_RERUN_HOURS=2
2014-02-13 17:06:35 ++ PREREQ_RERUN_SECONDS=7200
2014-02-13 17:06:35 +++ date +%s
2014-02-13 17:06:35 ++ NOW=1392291395
2014-02-13 17:06:35 +++ head -1 /home/ubuntuserver/devstack/.prereqs
2014-02-13 17:06:35 +++ echo 0
2014-02-13 17:06:35 ++ LAST_RUN=0
2014-02-13 17:06:35 ++ DELTA=1392291395
2014-02-13 17:06:35 ++ [[ 1392291395 -lt 7200 ]]
2014-02-13 17:06:35 ++ export_proxy_variables
2014-02-13 17:06:35 ++ [[ -n '' ]]
2014-02-13 17:06:35 ++ [[ -n '' ]]
2014-02-13 17:06:35 ++ [[ -n '' ]]
2014-02-13 17:06:35 +++ get_packages general g-api,g-reg,key,n-api,n-crt,n-obj,n-cpu,n-net,n-cond,c-sch,c-api,c-vol,n-sch,n-novnc,n-xvnc,n-cauth,horizon,rabbit,tempest,mysql
2014-02-13 17:06:35 +++ local 'services=general g-api,g-reg,key,n-api,n-crt,n-obj,n-cpu,n-net,n-cond,c-sch,c-api,c-vol,n-sch,n-novnc,n-xvnc,n-cauth,horizon,rabbit,tempest,mysql'
2014-02-13 17:06:35 ++++ _get_package_dir
2014-02-13 17:06:35 ++++ local pkg_dir
2014-02-13 17:06:35 ++++ is_ubuntu
2014-02-13 17:06:35 ++++ [[ -z deb ]]
2014-02-13 17:06:35 ++++ '[' deb = deb ']'
2014-02-13 17:06:35 ++++ pkg_dir=/home/ubuntuserver/devstack/files/apts
2014-02-13 17:06:35 ++++ echo /home/ubuntuserver/devstack/files/apts
2014-02-13 17:06:35 +++ local package_dir=/home/ubuntuserver/devstack/files/apts
2014-02-13 17:06:35 +++ local file_to_parse
2014-02-13 17:06:35 +++ local service
2014-02-13 17:06:35 +++ [[ -z /home/ubuntuserver/devstack/files/apts ]]
2014-02-13 17:06:35 +++ [[ -z precise ]]
2014-02-13 17:06:35 +++ for service in '${services//,/ }'
2014-02-13 17:06:35 +++ [[ -e /home/ubuntuserver/devstack/files/apts/general ]]
2014-02-13 17:06:35 +++ file_to_parse=' general'
2014-02-13 17:06:35 +++ [[ general == n-api ]]
2014-02-13 17:06:35 +++ [[ general == c-* ]]
2014-02-13 17:06:35 +++ [[ general == ceilometer-* ]]
2014-02-13 17:06:35 +++ [[ general == s-* ]]
2014-02-13 17:06:35 +++ [[ general == n-* ]]
2014-02-13 17:06:35 +++ [[ general == g-* ]]
2014-02-13 17:06:35 +++ [[ general == key* ]]
2014-02-13 17:06:35 +++ [[ general == q-* ]]
2014-02-13 17:06:35 +++ for service in '${services//,/ }'
2014-02-13 17:06:35 +++ [[ -e /home/ubuntuserver/devstack/files/apts/g-api ]]
2014-02-13 17:06:35 +++ [[ g-api == n-api ]]
2014-02-13 17:06:35 +++ [[ g-api == c-* ]]
2014-02-13 17:06:35 +++ [[ g-api == ceilometer-* ]]
2014-02-13 17:06:35 +++ [[ g-api == s-* ]]
2014-02-13 17:06:35 +++ [[ g-api == n-* ]]
2014-02-13 17:06:35 +++ [[ g-api == g-* ]]
2014-02-13 17:06:35 +++ [[ !  general =~ glance ]]
2014-02-13 17:06:35 +++ file_to_parse=' general glance'
2014-02-13 17:06:35 +++ for service in '${services//,/ }'
2014-02-13 17:06:35 +++ [[ -e /home/ubuntuserver/devstack/files/apts/g-reg ]]
2014-02-13 17:06:35 +++ [[ g-reg == n-api ]]
2014-02-13 17:06:35 +++ [[ g-reg == c-* ]]
2014-02-13 17:06:35 +++ [[ g-reg == ceilometer-* ]]
2014-02-13 17:06:35 +++ [[ g-reg == s-* ]]
2014-02-13 17:06:35 +++ [[ g-reg == n-* ]]
2014-02-13 17:06:35 +++ [[ g-reg ...
(more)
edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
4

answered 2014-08-01 06:10:22 -0500

We had the similar problem and resolved the following way: - If you are using stack user(or any other user for that matter), it is better to download the devstack.git from that user login and then all the folders created including /home/youruser/devstack will have necessary permissions. - Also try to do 'chown -R youruser devstack' and 'chmod 770 devstack' - Run clean.sh - Run stack.sh

edit flag offensive delete link more
0

answered 2015-11-05 23:11:32 -0500

shashidhar gravatar image

updated 2015-11-05 23:14:59 -0500

Whenever you create localrc file from root user and try to run stack.sh command from the stack user, following error will be encountered.

./stack.sh:line 594: /devstack/localrc: Permission denied Error on Exit root# cd /devstack

When such error is encountered, change the ownership of devstack directory to stack user using the following command

root@tempest:/devstack# chown -R stack:stack /devstack/

root@tempest:/devstack# ls -l

edit flag offensive delete link more
0

answered 2014-08-25 03:13:59 -0500

darren-wang gravatar image

permission, easy problem ~

edit flag offensive delete link more
0

answered 2014-02-13 16:17:22 -0500

jpichon gravatar image

2014-02-13 17:09:02 /home/ubuntuserver/devstack/tools/install_prereqs.sh: line 74: /home/ubuntuserver/devstack/.prereqs: Permission denied

https://github.com/openstack-dev/devs...

Looks like DevStack is trying to create a file in /home/ubuntuserver/devstack/ but cannot, check the directory/files permissions.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-02-13 11:49:56 -0500

Seen: 2,739 times

Last updated: Nov 05 '15