Ask Your Question
4

heat stack-list returns Invalid OpenStack Identity credentials

asked 2013-05-16 19:16:56 -0500

anonymous user

Anonymous

updated 2013-05-16 20:13:17 -0500

smaffulli gravatar image

My first time after installing heat on a multi node openstack cluster. All install commands went thru without issues until I invoked heat-api

Here's the detailed error

heat -d stack-list
INFO (connectionpool:195) Starting new HTTP connection (1): 192.168.5.18
DEBUG (connectionpool:289) "POST /v2.0/tokens HTTP/1.1" 200 None
DEBUG (http:112) curl -i -X GET -H 'X-Auth-User: admin' -H 'X-Auth-Token: 2e29c14e61be40fcb81814cea9f64af5' -H 'X-Auth-Key: secrete' -H 'Accept: application/json' -H 'User-Agent: python-heatclient' -H 'Content-Type: application/json' http://localhost:8004/v1/affc8e69b9ee48c393f26e8336c0657d/stacks?limit=20
No handlers could be found for logger "keystoneclient.middleware.auth_token"
DEBUG (http:122) 
HTTP/1.1 401 Unauthorized
date: Fri, 17 May 2013 00:05:18 GMT
content-length: 276
content-type: text/plain; charset=UTF-8
www-authenticate: Keystone uri='http://192.168.5.18:5000/v2.0/'

401 Unauthorized

This server could not verify that you are authorized to access the document you requested. Either you supplied the wrong credentials (e.g., bad password), or your browser does not understand how to supply the credentials required.

 Authentication required  

Invalid OpenStack Identity credentials.

--Ramashri

edit retag flag offensive close merge delete

Comments

I'm seeing this as well.

jasondunsmore gravatar imagejasondunsmore ( 2013-05-22 14:10:16 -0500 )edit

In my case, when I issue the same command as above, I see exactly the same result, BUT, my curl command DOES not have a X-Auth-User or X-Auth-Key passed in. It does have a X-Auth-Token passed in and I can confirm that the auth token is accurate and comes from Keystone. I get a 401 Unauthorized error. Having said that, if I do pass in the missing X-Auth-User and X-Auth-Key, in the above curl call, I do get a valid response. The question is, why are the X-Auth-User or X-Auth-Key, not being passed in? Any help is appreciated.

rupakg gravatar imagerupakg ( 2013-08-06 12:39:22 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2013-06-14 03:22:43 -0500

shardy gravatar image

The password 'secrete' may well be OK, since it's the default used in the keystone sample data script (/usr/share/openstack-keystone/sample_data.sh)

The problem will be easier to diagnose with the corresponding tail of tail /var/log/heat/api.log, it may be that some of the auth* values in /etc/heat/heat-api.conf are wrong (this needs to be configured to authenticate users with keystone, did you remember to set the host/tenant/user/password?)

Note if you're running grizzly the auth* settings are in api-paste.ini not heat-api.conf

edit flag offensive delete link more
1

answered 2013-06-12 05:58:00 -0500

gfidente gravatar image

works fine for me, I think this is a misconfiguration issue

Looks like the password it is passing is 'secrete' , see X-Auth-Key: secrete , is that mistyped maybe?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-05-16 19:16:56 -0500

Seen: 3,144 times

Last updated: Jun 14 '13