Chrony on controller node doesn't list the compute node

asked 2020-08-24 21:08:36 -0500

Walsh_C gravatar image

Hi Everyone,

I am new to openstack. Need the help for the NTP setting.

I was setting the environment on both controller and compute node. When I setting chrony on controller node and type " chronyc sources" it doesn't shows the compute node on the list. An the synchronization service doesn't work properly between controller and compute node. I can't figure out what is the problem. Need some help.

Here is my chrony.conf on the compute node

# Welcome to the chrony configuration file. See chrony.conf(5) for more
# information about usuable directives.

# This will use (up to):
# - 4 sources from ntp.ubuntu.com which some are ipv6 enabled
# - 2 sources from 2.ubuntu.pool.ntp.org which is ipv6 enabled as well
# - 1 source from [01].ubuntu.pool.ntp.org each (ipv4 only atm)
# This means by default, up to 6 dual-stack and up to 2 additional IPv4-only
# sources will be used.
# At the same time it retains some protection against one of the entries being
# down (compare to just using one of the lines). See (LP: #1754358) for the
# discussion.
#
# About using servers from the NTP Pool Project in general see (LP: #104525).
# Approved by Ubuntu Technical Board on 2011-02-08.
# See http://www.pool.ntp.org/join.html for more information.
#pool ntp.ubuntu.com        iburst maxsources 4
#pool 0.ubuntu.pool.ntp.org iburst maxsources 1
#pool 1.ubuntu.pool.ntp.org iburst maxsources 1
#pool 2.ubuntu.pool.ntp.org iburst maxsources 2
server 192.168.0.11 iburst

# This directive specify the location of the file containing ID/key pairs for
# NTP authentication.
keyfile /etc/chrony/chrony.keys

# This directive specify the file into which chronyd will store the rate
# information.
driftfile /var/lib/chrony/chrony.drift

# Uncomment the following line to turn logging on.
#log tracking measurements statistics

# Log files location.
logdir /var/log/chrony

# Stop bad estimates upsetting machine clock.
maxupdateskew 100.0

# This directive enables kernel synchronisation (every 11 minutes) of the
# real-time clock. Note that it can’t be used along with the 'rtcfile' directive.
rtcsync

# Step the system clock instead of slewing it if the adjustment is larger than
# one second, but only in the first three clock updates.
makestep 1 3

Here is the chrony.conf on the controller node

# Welcome to the chrony configuration file. See chrony.conf(5) for more
# information about usuable directives.

# This will use (up to):
# - 4 sources from ntp.ubuntu.com which some are ipv6 enabled
# - 2 sources from 2.ubuntu.pool.ntp.org which is ipv6 enabled as well
# - 1 source from [01].ubuntu.pool.ntp.org each (ipv4 only atm)
# This means by default, up to 6 dual-stack and up to 2 additional IPv4-only
# sources will be used.
# At the same time it retains some protection against one of the entries being
# down (compare to just using one of the lines). See (LP: #1754358) for the
# discussion.
#
# About using servers from the NTP Pool Project in general see ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2020-08-24 22:06:42 -0500

updated 2020-08-24 22:12:29 -0500

You didn't configure the compute node as an NTP server (there is no allow clause). Therefore, it doesn't appear in the controller's time sources.

In fact, you didn't configure any time source on the controller (no server or pool clause).

Furthermore, this line in the controller configuration doesn't look correct (I am not sure):

allow 192.168/24

As a result, I guess the compute node doesn't get NTP services from the controller. Try, for example, 192.168.0.0/24, or allow all. I suppose that 192.168.0.11 is the controller, correct?

edit flag offensive delete link more

Comments

Thank you for the reply.

I set the controller node (Yes, 192.168.0.11) itself as the NTP server, so I configure following in chrony.conf on controller

server 192.168.0.11 iburst

And I also change the line allow 192.168/24 into 192.168.0.0/24 But the chronyc sources output is same

Walsh_C gravatar imageWalsh_C ( 2020-08-24 22:33:04 -0500 )edit

This line

server 192.168.0.11 iburst

tells the controller to use itself as NTP source. I don't know if this is possible at all, or if other configuration settings are required for this scenario. Perhaps you need the local directive to synchronize with the local clock.

Bernd Bausch gravatar imageBernd Bausch ( 2020-08-25 17:38:46 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2020-08-24 21:07:54 -0500

Seen: 29 times

Last updated: Aug 24