Give VM access to outside world (question)

asked 2020-08-15 14:57:03 -0500

bateman231 gravatar image

updated 2020-08-15 20:53:46 -0500

So i mounted my VM, and from the host i can ssh into it and all. but my issue is i want it to be able to see it from other machines on my home-network, ping into them, ssh and what not, and also give them internet access which they don't have and find it extremely stressful, ill put a list of things i tried unsuccessfully.

-Make router and set a floating IP (only made it visible for the host)

-Add extra rules to the security group (SSH, HTTP, HTTPS, ICMP, TCP, UDP)

-Try a different image (tried cirros, debian and ubuntu, no luck so far)

-Added a number of different parameters in the Local.conf using as examples these 2 pages.

https://docs.openstack.org/devstack/latest/networking.html (https://docs.openstack.org/devstack/l...)

https://docs.openstack.org/devstack/latest/guides/neutron.html (https://docs.openstack.org/devstack/l...)

(note: i have 2 physical network interfaces and the second has no ip assigned to it)

-Tried making a new flat network using horizon but it just sometimes throws me an error or does nothing

I'm using ubuntu 18.04 LTS and Devstack version: Victoria.

Any help would be really appreciated as i have been on this for a few months on my free time trying it to make it work for a personal project but to no avail.

the local.conf contains the next (can't add images yet)

-

[[local|localrc]]

ADMIN_PASSWORD=secret

DATABASE_PASSWORD=$ADMIN_PASSWORD

RABBIT_PASSWORD=$ADMIN_PASSWORD

SERVICE_PASSWORD=$ADMIN_PASSWORD

PUBLIC_INTERFACE=enp2s0

-

edit retag flag offensive close merge delete

Comments

I guess you did https://docs.openstack.org/devstack/l..., correct? Please add local.conf to your question, and the output of ip a show br-ex. How are your instances networked?

What do you mean by "only made it visible for the host"?

Bernd Bausch gravatar imageBernd Bausch ( 2020-08-15 19:21:57 -0500 )edit

by visible i mean that the host machine can ping to the VMs, SSH into them and interact with them (couldn't do it before setting the floating ip) but only that, no real access to the outside network. and the command that you asked me to run shows this https://imgur.com/lVQhzqH

bateman231 gravatar imagebateman231 ( 2020-08-15 20:54:33 -0500 )edit

br-ex has no outside network address, which explains why instances aren't connected to the external network.

I guess that the instructions are not complete. Try setting FLOATING_RANGE, PUBLIC_NETWORK_GATEWAY and Q_FLOATING_ALLOCATION_POOL as well. I believe GATEWAY is the desired address of br-ex.

Bernd Bausch gravatar imageBernd Bausch ( 2020-08-16 00:43:13 -0500 )edit

Not sure if you can repair the current config. Perhaps by adding an external address to br-ex, then creating a second external network (see https://docs.openstack.org/neutron/la...).

Bernd Bausch gravatar imageBernd Bausch ( 2020-08-16 00:47:57 -0500 )edit

To confirm that enp2s0 is plugged into br-ex, also run ovs-vsctl show.

Bernd Bausch gravatar imageBernd Bausch ( 2020-08-16 00:49:56 -0500 )edit