How to Install OpenStack Glance on CentOS 8?

asked 2020-08-03 15:16:20 -0500

MichaelCropper gravatar image

updated 2020-08-07 14:35:45 -0500

Up to here; https://docs.openstack.org/glance/ussuri/install/install-rdo.html (https://docs.openstack.org/glance/uss...)

And this doesn't work;

$ openstack user create --domain default --password-prompt glance

The error message is;

"Missing value auth-url required for auth plugin password"

Thoughts?

Regards,

Michael

UPDATE

I've just created the environment variables with the following commands;

sudo nano ./admin-openrc

Then;

export OS_PROJECT_DOMAIN_NAME=Default
export OS_USER_DOMAIN_NAME=Default
export OS_PROJECT_NAME=admin
export OS_USERNAME=admin
export OS_PASSWORD=password
export OS_AUTH_URL=http://192.168.0.100:5000/v3
export OS_IDENTITY_API_VERSION=3
export OS_IMAGE_API_VERSION=2

Yet when I run the following commands;

. admin-openrc

openstack user create --domain default --password-prompt glance

I then get the following error;

Gateway Timeout (HTTP 504)

Not really sure what I need to do to go about debugging this?

I've just checked a few of the services that are supposed to start on boot, but they aren't all running. Not sure if that is related or not? And when I tried to start some of them, they wouldn't start. I must not have noticed that when I was installing them that they didn't start up after running the commands. Looks like something else I'll need to create a few more questions for to figure out those problems too.

edit retag flag offensive close merge delete

Comments

1

This looks like you have not set the required environment variables.

Bernd Bausch gravatar imageBernd Bausch ( 2020-08-03 19:07:32 -0500 )edit

Thanks. Looking at that guide, it implies that you need to create one of these files for every Project? It was my understanding that projects could be self-serve via Horizon once set up?

MichaelCropper gravatar imageMichaelCropper ( 2020-08-07 14:15:24 -0500 )edit

Just updated the original question with info about what i've changed and what the problem is.

MichaelCropper gravatar imageMichaelCropper ( 2020-08-07 14:36:09 -0500 )edit

You solved the original problem.

Gateway Timeout probably means that Apache can't communicate with Glance. Is Glance running at all?

Bernd Bausch gravatar imageBernd Bausch ( 2020-08-07 17:28:52 -0500 )edit

projects could be self-serve via Horizon once set up

I don't understand this question, but in this case you are not using Horizon but the CLI.

Bernd Bausch gravatar imageBernd Bausch ( 2020-08-07 17:29:57 -0500 )edit