Ask Your Question
0

Struggling to install RabbitMQ on Controller Node

asked 2020-07-25 15:13:35 -0500

MichaelCropper gravatar image

updated 2020-07-25 15:35:30 -0500

Managed to get to this part in the installation guide successfully (woo, progress!), https://docs.openstack.org/install-guide/environment-messaging-rdo.html (https://docs.openstack.org/install-gu...)

Then when running the following command (CentOS 8), it fails;

rabbitmqctl add_user openstack password123

(note.... I've used a slightly more secure password than that :-) )

The error is;


[root@controller ~]# rabbitmqctl add_user openstack password123 Error: unable to perform an operation on node 'rabbit@controller'. Please see diagnostics information and suggestions below.

Most common reasons for this are:

  • Target node is unreachable (e.g. due to hostname resolution, TCP connection or firewall issues)
  • CLI tool fails to authenticate with the server (e.g. due to CLI tool's Erlang cookie not matching that of the server)
  • Target node is not running

In addition to the diagnostics info below:

  • See the CLI, clustering and networking guides on https://rabbitmq.com/documentation.html to learn more
  • Consult server logs on node rabbit@controller
  • If target node is configured to use long node names, don't forget to use --longnames with CLI tools

DIAGNOSTICS

attempted to contact: [rabbit@controller]

rabbit@controller: * unable to connect to epmd (port 4369) on keystone: nxdomain (non-existing domain)

Current node details: * node name: 'rabbitmqcli-30475-rabbit@controller' * effective user's home directory: /var/lib/rabbitmq * Erlang cookie hash: RJFprQ150jL+a0zgqAuoPA==


Then when checking the logs;

Nothing at all. Just a message saying that the service has successfully started.

Thoughts?

Note: I've recently changed the hostname from 'keystone' to 'controller' after realising that this is a better name, I've updated most of the names in the above, but it looks as though something is kind of out of sync perhaps. I've tried renaming the hostname back to 'keystone', and also as 'controller' but similar error messages appear. Not sure if this is related or not.

To add, I'm thinking there may be an issue with DNS name resolution. But this is running on a pure localhost setup, so not sure if there is anything I need to do here? Just adding info in case this may be an issue that I need to consider that is not in the OpenStack Docs?

More to add.... Looking at the CentOS 8 logs, there is a note saying;

"SELinux is preventing 9_dirty_io_sche from write access on the file rabbitmq.conf. For complete SELinux messages run: sealert -l 32fa043c-33fb-4aa0-972a-435f63050cbe"

Regards, Michael

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2020-07-30 11:15:15 -0500

MichaelCropper gravatar image

How very odd... came back today to have a play and the same command that was failing last time is now working. Perhaps the server needs a reboot after the installation of RabbitMQ before adding the user. I can only assume that the rabbitmqctl is loaded on boot rather than as a service.

Good old IT solution.... turn it off and back on again :-)

I also tried to run the command as the rabbitmq user, but you can't actually do that since that user is Linux user that is not allowed to login so you can't "su - rabbitmq" to then run the script.

edit flag offensive delete link more

Comments

su -s /bin/sh rabbitmq

tjoen gravatar imagetjoen ( 2020-07-30 16:33:15 -0500 )edit
0

answered 2020-07-26 02:21:07 -0500

tjoen gravatar image

Had the same problem: rabbitmq doesn't want "rabbitmqctl add_user" to be run as root, only as user rabbitmq

edit flag offensive delete link more

Comments

What was the solution? I've currently only got a root user set up on the VM. Do I need to set up a non-root user, then run that command again?

MichaelCropper gravatar imageMichaelCropper ( 2020-07-26 15:15:02 -0500 )edit

According to rabbitmq-server.service rabbitmq is run as rabbitmq

tjoen gravatar imagetjoen ( 2020-07-28 04:53:17 -0500 )edit

So you need to run that command as the rabbitmq user rather than as root user? I'll give that a go.

MichaelCropper gravatar imageMichaelCropper ( 2020-07-28 07:59:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2020-07-25 15:13:35 -0500

Seen: 0 times

Last updated: Jul 30