tripleo cluster failed

asked 2020-07-22 07:58:43 -0500

Rahul Pathak gravatar image

Hi,

I have installed tripleo openstack version rocky containerized with 3 controllers and 2 compute BM and 1 Vm as undercloud.

Overcloud cluster start failing once number of networks in overcloud reach more than 70. Lots of resources failure issue shown there. I don't know why HA cluster failed after 70 networks in OC.

Is some kind of threshold in tripleo configuration? so it is restricted not to create more than 70 or 80 netwoks. How could i fix this?

I did not see such issue when I am using redhat platform and it's repos. This issue coming in opensource repos on Centos 7 . Please help how to fix this issue so I can scale up my openstack upto 2000 vms in this situation it's not possible.

edit retag flag offensive close merge delete

Comments

Have you any monitoring enabled to see the load on the nodes? I’ve seen a control node acting out pretty hard (OOM Killer) where openvswitch used RAM heavily. Although it could have been a bug fixed by updates I’d still take a look at that.

eblock gravatar imageeblock ( 2020-07-23 05:25:25 -0500 )edit

Yes, I had checked load on controller. Actually when total number of network in OC goes more than 70+ cluster start failing when creating number of network and projects with script. At that time no such heavy load on control node. There is lots of memory available at that time too.

Rahul Pathak gravatar imageRahul Pathak ( 2020-07-24 10:57:05 -0500 )edit

Then you have to go through the logs (neutron), but I’m not familiar with tripleo, so I can’t tell what other logs there may be to have a look at, but I’d start with neutron.

eblock gravatar imageeblock ( 2020-07-25 12:20:43 -0500 )edit