Ask Your Question
0

create-service not saved in database

asked 2012-06-28 09:32:27 -0500

Hi all,

on my keystone node I can create user and tenant that are kept in database but not services. if i restart the keystone service I loose only the data from keystone.service table.

I can't figure out why. Do you have any idea about that?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-07-02 18:33:45 -0500

heckj gravatar image

What driver are you using for the catalog? I suspect you're using KVS there, when you probably want to use the SQL backend.

Look under etc/keystone.conf - I'd recommend the following (and suspect it isn't set this way right now):

[catalog]

dynamic, sql-based backend (supports API/CLI-based management commands)

driver = keystone.catalog.backends.sql.Catalog

edit flag offensive delete link more
0

answered 2012-07-03 08:58:43 -0500

Actually I think the issue was somehow related to quantum and since I removed it from my 2 nodes and rolled back to a single node install (I need to have a working demo for tomorrow) all my db records are fine.

Anyway I'm gonna have to go back to using quantum soon (next week) so I'm probably gonna upate this post with any other workarroud I find.

Thanx a lot Joseph.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-06-28 09:32:27 -0500

Seen: 25 times

Last updated: Jul 03 '12