Can you use a hostname instead of an IP address in devstack?

asked 2020-07-08 07:28:59 -0500

jengbers gravatar image

I would like the public endpoints created by running ./stack.sh to contain a hostname instead of the IP address of the VM on which the devstack is running. That way I could develop the clients and Horizon locally by resolving the hostname to the public IP address of the VM. However, when I try to do that by setting:

HOST_IP=192.168.1.55
SERVICE_HOST=devstack-host

The endpoints will be as I want them to be, but then the etcd service doesn't start because that expects an IP address:

etcdmain: error verifying flags, expected IP in URL for binding (http://devstack-host:2379). See 'etcd --help'

Is there any way a setup like this is possible by changing the configuration of the devstack?

edit retag flag offensive close merge delete

Comments

1

It's etcd that insists on an IP address. I don't know why, but see https://github.com/etcd-io/etcd/blob/....

Since Devstack uses SERVICE_HOST as a parameter to etcd, I am afraid you have to change the code to achieve this.

Bernd Bausch gravatar imageBernd Bausch ( 2020-07-08 10:26:34 -0500 )edit