Ask Your Question
0

nova-api on CentOS

asked 2012-01-18 18:47:07 -0500

ryan-tidwell gravatar image

I'm getting the following error when attempting to run nova-api on CentOS:

Traceback (most recent call last): File "/usr/bin/nova-api", line 41, in <module> from nova import service File "/usr/lib/python2.6/site-packages/nova/service.py", line 36, in <module> from nova import wsgi File "/usr/lib/python2.6/site-packages/nova/wsgi.py", line 27, in <module> from paste import deploy File "/usr/lib/python2.6/site-packages/paste/deploy/__init__.py", line 3, in <module> from paste.deploy.loadwsgi import * File "/usr/lib/python2.6/site-packages/paste/deploy/loadwsgi.py", line 11, in <module> from paste.deploy.util import fix_call, lookup_object ImportError: cannot import name fix_call

pip freeze shows the following versions of libraries installed:

IPy==0.70 M2Crypto==0.20.2 MySQL-python==1.2.3c1 Paste==1.7.5.1 PasteDeploy==1.5.0 PasteScript==1.7.5 PyXML==0.8.4 PyYAML==3.09 Routes==1.12.3 SQLAlchemy==0.6.4 Tempita==0.4 WebOb==1.2b2 amqplib==1.0.2 anyjson==0.3.1 argparse==1.0.1 boto==1.9b carrot==0.10.7 decorator==3.0.1 distribute==0.6.10 django-registration==0.7 euca2ools==1.2 eventlet==0.9.15 glance==2012.1 greenlet==0.3.1 httplib2==0.7.1 iniparse==0.3.1 kombu==1.4.1 lockfile==0.8 lxml==2.2.3 mox==0.5.3 netaddr==0.7.5 nova==2012.1 prettytable==0.5 pyOpenSSL==0.10 pycurl==7.19.0 pygpgme==0.1 python-daemon==1.5.5 python-gflags==1.4 python-novaclient==2.6.4 redis==2.0.0 scgi==1.14 simplejson==2.0.9 sqlalchemy-migrate==0.6 suds==0.4.1 tornado==1.1 urlgrabber==3.9.1 wsgi-intercept==0.5.1 wsgiref==0.1.2 xattr==0.6.1 yum-metadata-parser==1.1.2

Any idea what is wrong here?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2012-11-22 18:47:25 -0500

I have the same problem after installing quantum dependencies of quantum via PIP... How did you resolv the problem?

edit flag offensive delete link more
0

answered 2012-01-20 00:24:07 -0500

ryan-tidwell gravatar image

Got past this issue and can now run on CentOS 6.0. There was some confusion between the Python dependencies installed as RPM's via yum and the dependencies installed directly with pip. I think the moral of the story is to avoid pip at all costs.

edit flag offensive delete link more
0

answered 2012-11-23 20:24:44 -0500

Please don't use pip to setup quantum. I'd advise to use the EPEL packages which are now at the Folsom release. https://fedoraproject.org/wiki/Getting_started_with_OpenStack_EPEL (https://fedoraproject.org/wiki/Gettin...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-01-18 18:47:07 -0500

Seen: 69 times

Last updated: Nov 23 '12