cpu_mode changes in nova.conf changes not taking effect

asked 2020-06-21 06:58:46 -0500

htyeig gravatar image

I have devstack up and running, and I'm trying to get an application running on one of my instances. When I try running it, I get an error saying SSS3 is not supported by the CPU (which is QEMU Virtual CPU version 2.5+)

I tried making changes to /etc/nova/nova.conf to make cpu_mode use host-model at first and changed it to host-passthrough later. It didn't work on both accounts. I still get the same SSSE3 not supported error

Is there something else that needs to be done? I restarted all devstack services after every change I made to nova.conf, but it looked like none of the changes actually worked.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2020-06-21 11:54:25 -0500

htyeig gravatar image

So I figured it out, and I'm not sure if the openstack docs were out of date, but all the information that kept coming up when I googled said I had to make config changes to /etc/nova/nova.conf...totally exasperated after hundreds of fruitless google searches, I decide to go to the /etc/nova/ directory, and what do I see? A file named nova-cpu.conf. I open it up and it looks similar to the nova.conf file, so I make changes to it and...lo and behold, everything works!

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2020-06-21 06:57:57 -0500

Seen: 59 times

Last updated: Jun 21