Configuration noVNC-based VNC console

asked 2020-06-09 04:35:12 -0500

gsic-emic gravatar image

Hello,

I am installing Openstack Ussuri and I have no idea how to configure novnc console. I have a controller node and a compute node.

The guides show this options:

In nova.conf (controller):

[vnc]
enabled = true
# ...
server_listen = $my_ip
server_proxyclient_address = $my_ip

In nova.conf (compute):

[vnc]
# ...
enabled = true
server_listen = 0.0.0.0
server_proxyclient_address = $my_ip
novncproxy_base_url = http://controller:6080/vnc_auto.html

Besides, I read this page: https://docs.openstack.org/nova/ussur..., but I am totally stuck with this issue.

Could anyone help me with the nova config files and apache2 configuration in order to set up the console?

Thanks in advance

edit retag flag offensive close merge delete

Comments

my_ip is the IP address of the management interface, i.e. the network interface connected to the management network. All other options are constants; you can copy and paste them, except if the controller has a different name than "controller".

Bernd Bausch gravatar imageBernd Bausch ( 2020-06-10 00:49:08 -0500 )edit

No particular Apache configuration is required as far as I know.

Bernd Bausch gravatar imageBernd Bausch ( 2020-06-10 00:49:39 -0500 )edit

Thanks, it works. The vnc console is accesible via the url configure in novncproxy_base_url (is http). The connection with QUEMU is unencrypted. How can I solve it? I would like to access via https to the vnc console Moreover the vnc console iframe in Horizon does not appear.

gsic-emic gravatar imagegsic-emic ( 2020-06-10 03:35:32 -0500 )edit

Sorry, I can't tell you what might be wrong with your Horizon, and how to use https.

Bernd Bausch gravatar imageBernd Bausch ( 2020-06-10 04:24:45 -0500 )edit

I mean how configure ssl to access novnc via HTTPS. If I put that this doesn't works (previously I add the key and cert to nova.conf in controller node) novncproxy_base_url = https://controller:6080/vnc_auto.html Horizon doesn't show the console iframe because is a http content inside https page

gsic-emic gravatar imagegsic-emic ( 2020-06-10 05:40:36 -0500 )edit