microstack.init error

asked 2020-06-09 04:16:58 -0500

updated 2020-06-09 07:01:59 -0500

eblock gravatar image

Hi,

I am using ubuntu 18.04. I am trying to deploy multinode openstack.

I am executing the command- sudo microstack.init, I am getting the following error. Kindly help out.

mudassir@mudassir-VirtualBox:~$ sudo microstack.init
[sudo] password for mudassir:
Do you want to setup clustering? (yes/no) [default=yes] > yes
2020-06-09 14:40:28,329 - microstack_init - INFO - Configuring clustering ...
What is this machines' role? (control/compute) > compute
Please enter a cluster password >
Please re-enter password >
Please enter the ip address of the control node [default=10.0.2.15] > 10.0.2.15
Please enter the ip address of this node [default=10.0.2.15] > 10.0.2.15
2020-06-09 14:41:07,865 - microstack_init - INFO - I am a compute node.
Traceback (most recent call last):
  File "/snap/microstack/196/bin/microstack_join", line 11, in <module>
    load_entry_point('microstack-cluster==0.0.1', 'console_scripts', 'microstack_join')()
  File "/snap/microstack/196/lib/python3.6/site-packages/cluster/client.py", line 25, in join
    resp.json))
Exception: Failed to get info from control node: <bound method Response.json of <Response [500]>>
Traceback (most recent call last):
  File "/snap/microstack/196/bin/microstack_init", line 11, in <module>
    load_entry_point('microstack-init==0.0.1', 'console_scripts', 'microstack_init')()
  File "/snap/microstack/196/lib/python3.6/site-packages/init/main.py", line 122, in main
    question.ask()
  File "/snap/microstack/196/lib/python3.6/site-packages/init/questions/question.py", line 210, in ask
    self.yes(awr)
  File "/snap/microstack/196/lib/python3.6/site-packages/init/questions/__init__.py", line 84, in yes
    check_output('microstack_join')
  File "/snap/microstack/196/lib/python3.6/site-packages/init/shell.py", line 81, in check_output
    universal_newlines=True).strip()
  File "/snap/microstack/196/usr/lib/python3.6/subprocess.py", line 356, in check_output
    **kwargs).stdout
  File "/snap/microstack/196/usr/lib/python3.6/subprocess.py", line 438, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '('microstack_join',)' returned non-zero exit status 1.
edit retag flag offensive close merge delete

Comments

Did you mixup ip addresses? I have no idea how microstack works but have you tried to assign the control role to that node you're launching the init command from?

eblock gravatar imageeblock ( 2020-06-09 07:07:03 -0500 )edit