Ask Your Question
0

Networking issue

asked 2020-06-08 01:09:29 -0500

govindsmenokee gravatar image

I have openstack setup on a laptop(all in one setup). The setup was done using devstack. No matter what changes I make I'm not able to ping or ssh into instance.

The local wifi network the laptop is connected to is 192.168.68.0/24

I've tried creating public network based on this. Also private network is 10.0.0.0/24 I've created a router to interface these two networks.

The problem is when I'm assigning a floating ip from my public network(local wifi network) the ip that is getting allocated is nowhere to be found in my local wifi network. I'm not able to find that ip allocation in the DHCP logs of the local wifi network.

Can someone please help me out. Ive been trying to resolve this for almost one week now.

edit retag flag offensive close merge delete

Comments

By default, Devstack's publicnetwork is isolated. To map it to your physical network, follow instructions at https://docs.openstack.org/devstack/l....

Bernd Bausch gravatar imageBernd Bausch ( 2020-06-08 04:29:41 -0500 )edit

Hey thank you for the quick reply. I tried out this method too. I only have one interface enp1s0 on my server. And after following the guideline you gave I was not able to ping even the devstack server. I used the Shared Guest Interface┬ approach specified in the guideline.

govindsmenokee gravatar imagegovindsmenokee ( 2020-06-08 08:38:12 -0500 )edit

One detail: You won't find the floating IP in any DHCP logs because DHCP is not involved. Let alone local WiFi logs - your local WiFi network knows nothing about that floating IP.

You should see the floating IP in the router namespace.

Does the Devstack host have connectivity to the floating IP?

Bernd Bausch gravatar imageBernd Bausch ( 2020-06-08 09:37:42 -0500 )edit

Then in that case how will a machine in the local network(wifi network which the devstack host is also connected to) talk to the instance within devstack host. My devstack host's "ip addr" is having this output -> imgur.com/2aeiWfF and local.conf is -> imgur.com/szxkSV8

govindsmenokee gravatar imagegovindsmenokee ( 2020-06-08 11:00:22 -0500 )edit

The local.conf looks OK, but after running stack.sh there should be several Openvswitsch bridges in the "ip addr" output. Are you sure stack.sh was successful?

Also: Do you see the floating IP in the router's network namespace, and does the Devstack host have connectivity to the floating IP?

Bernd Bausch gravatar imageBernd Bausch ( 2020-06-08 18:29:17 -0500 )edit

1 answer

Sort by ┬╗ oldest newest most voted
0

answered 2020-06-10 06:40:23 -0500

Since I need more space than 256 characters, I write an answer, although I am not sure whether it works for you. I managed to set up an Ussuri Devstack on a virtual machine that has a single network interface, and that is connected to the outside network.

TL;DR: The instructions don't work out of the box on Ubuntu 18.04. Some tweaking is required.

My home network is 192.168.1.0/24. This the local.conf:

[[local|localrc]]
ADMIN_PASSWORD=pw
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD

PUBLIC_INTERFACE=ens3
HOST_IP=192.168.1.200
FLOATING_RANGE=192.168.1.0/24
PUBLIC_NETWORK_GATEWAY=192.168.1.1
Q_FLOATING_ALLOCATION_POOL=start=192.168.1.230,end=192.168.1.250

I am not sure about the meaning of PUBLIC_NETWORK_GATEWAY, but I just followed the instructions.

Main tweak: /etc/resolv.conf

When running stack.sh, the internet connection breaks at some point, which breaks stack.sh. It turns out that name resolution ceases working, although I put the correct nameservers in the /etc/netplan config file. Too tired to troubleshoot this, I decided to use a manual, static /etc/resolv.conf that contains my nameservers, and to disable systemd-resolved (I even masked it to be certain it won't be revived by stack.sh).

Other tweaks

  • I also added the Devstack host to /etc/hosts, although it's probably not necessary.
  • Since this was a VM that I started from a snapshot, it's clock was a day late. I corrected that as well.
  • After stack.sh, br-ex had the IP address of my gateway 192.168.1.1. This doesn't work, and I simply removed the address.

Result

stack.sh runs through, I can create an instance that has access to the internet, and after giving it a floating IP I can access the instance from other devices on my home network.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2020-06-08 01:09:29 -0500

Seen: 82 times

Last updated: Jun 10