Wrong adapter being chosen even provided correctly

asked 2020-05-31 13:44:42 -0500

uday kiran reddy gravatar image

I have two network adapters.

hostonly and nat.

hostonly IP: 192.168.33.10 adapter: eth1

nat IP: 10.0.2.15 adapter: eth0

It is using eth0 instead of eth1 even mentioned in command.

The command I used for installation:

packstack --allinone --provision-demo=n --os-neutron-ovs-bridge-mappings=extnet:br-ex --os-neutron-ml2-mechanism-drivers=openvswitch --os-neutron-l2-agent=openvswitch --os-neutron-ovs-bridge-interfaces=br-ex:eth1 --os-neutron-ml2-type-drivers=vxlan,flat --os-neutron-ml2-tenant-network-types=vxlan

O/p:

Copying Puppet modules and manifests
[ DONE ]

Applying 10.0.2.15_controller.pp

10.0.2.15_controller.pp: [ DONE ]

Applying 10.0.2.15_network.pp

10.0.2.15_network.pp: [ DONE ]

Applying 10.0.2.15_compute.pp

10.0.2.15_compute.pp: [ DONE ]

Applying Puppet manifests
[ DONE ]

Finalizing
[ DONE ]

* Installation completed successfully ***

Additional information:

  • A new answerfile was created in: /root/packstack-answers-20200531-171952.txt

  • Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.

  • File /root/keystonerc_admin has been created on OpenStack client host 10.0.2.15. To use the command line tools you need to source the file.

  • To access the OpenStack Dashboard browse to http://10.0.2.15/dashboard .

Please, find your login credentials stored in the keystonerc_admin in your home directory.

  • Because of the kernel update the host 10.0.2.15 requires reboot.

  • The installation log file is available at: /var/tmp/packstack/20200531-171950-tpWoh4/openstack-setup.log

  • The generated manifests are available at: /var/tmp/packstack/20200531-171950-tpWoh4/manifests

edit retag flag offensive close merge delete

Comments

You ask for eth1 to be connected to br-ex. You don't ask for the dashboard to be accessed via eth1. I don't know if there is such an option.

Bernd Bausch gravatar imageBernd Bausch ( 2020-05-31 14:02:23 -0500 )edit

http://10.0.2.15/dashboard is the dahboard url as in console output. But, this is IP for nat adapter. So, we can't access it. How to configure to access from 192.168.33.10 : host-only adapter

uday kiran reddy gravatar imageuday kiran reddy ( 2020-06-01 11:34:14 -0500 )edit

As I said, I don't know if there is such an option. I would try swapping the interfaces so that eth0 has the 192.168.33.10 address.

Why can't you access the NAT adapter? This looks like VirtualBox, which features port forwarding.

Bernd Bausch gravatar imageBernd Bausch ( 2020-06-01 16:42:59 -0500 )edit

You could also try the option --os-controller-host=192.168.33.10.

Bernd Bausch gravatar imageBernd Bausch ( 2020-06-01 17:54:45 -0500 )edit

I tried this parameter with IP 172.168.33.10 and getting below error.

https://raw.githubusercontent.com/ukreddy-erwin/openstacklogs/master/06-03-2020/install.log (https://raw.githubusercontent.com/ukr...)

uday kiran reddy gravatar imageuday kiran reddy ( 2020-06-02 14:12:48 -0500 )edit