Ask Your Question
0

pci_passthrough alias and flavor setting for a GPU

asked 2020-05-28 06:59:54 -0500

anonymous user

Anonymous

We have a single GPU device detected as two devices into the compute host as below: $ lspci -nn | grep "83:00." 83:00.0 Processing accelerators [1200]: Xilinx Corporation Device [10ee:5020] 83:00.1 Processing accelerators [1200]: Xilinx Corporation Device [10ee:5021]

We have to passthrough this device in rocky. We have set the PCI alias in the controller host as below: [pci] alias = { "vendor_id":"10ee", "product_id":"5020", "device_type":"type-PCI", "name":"Xilinx5020" } alias = { "vendor_id":"10ee", "product_id":"5021", "device_type":"type-PCI", "name":"Xilinx5021" }

but openstack does not allow setting flavor with two PCI aliases as show below: | 1b2a1111-111e-11df-1122-8f71111fb3d6 | pciflavor | 16384 | 100 | 0 | 4 | True | | 1.0 | pci_passthrough:alias='Xilinx5020:1,Xilinx5021:1',

Is there a way to add this device as single pci alias for such device or a way to add multiple pci_passthrough aliases in a better way inside a flavor ?

Thanks!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2020-06-02 03:54:22 -0500

SCN gravatar image

[pci] alias = { "vendor_id":"10ee", "product_id":"5020", "device_type":"type-PCI", "name":"Xilinx5020" } alias = { "vendor_id":"10ee", "product_id":"5021", "device_type":"type-PCI", "name":"Xilinx5021" }

with flavor set as below openstack flavor set pciflavor --property "pci_passthrough:alias"="Xilinx5020:1,Xilinx5021:1"

This worked out well during further testing and configuration. We had to enable IOMMU first for the device to get passthrough.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2020-05-28 06:59:54 -0500

Seen: 16 times

Last updated: May 28