Ask Your Question
0

DHCP problem

asked 2013-07-11 13:36:19 -0500

ptc61891 gravatar image

I've been trying to debug my networking issues for nearly a month now and I think im getting closer. I have a single node setup of openstack, installed through packstack and RDO scripts on an RHEL6.4 machine. In running a Cirros image and looking at the log files i found this error: Starting logging: OK Initializing random number generator... done. Starting network... udhcpc (v1.18.5) started Sending discover... Sending discover... Sending discover... No lease, failing WARN: /etc/rc3.d/S40network failed cloudsetup: checking http://169.254.169.254/20090404/metadata/instanceid (http://169.254.169.254/20090404/metad...) wget: can't connect to remote host (169.254.169.254): Network is unreachable cloudsetup: failed 1/30: up 9.93. request failed wget: can't connect to remote host (169.254.169.254): Network is unreachable

I killed all dnsmasq and restarted nova. I then ran the:

ps aux | grep dnsmasq

command expecting to find some kind of evidence that the service restarted but no such luck. This is all it shows and Im stuck:

root 11735 0.0 0.0 103244 856 pts/2 S+ 09:26 0:00 grep dnsmasq

Please help

edit retag flag offensive close merge delete

7 answers

Sort by ยป oldest newest most voted
0

answered 2013-07-18 19:20:37 -0500

maoliping455 gravatar image

Not sure I have unstood what you said... ^_^ So you mean you use nova-network? The log shows that your VM has send dhcp req, but it does not get response from dnsmasq. You can run dhcpc in your VM in VNC, and use tcpdump to see where the req packet be, then you can see what's the problem. BTW, after you kill dnsmasq and restart nova-network, do you mean your dnsmasq is not up? You can boot another VM, I think dnsmasq should be up. Otherwise, you need to check if there is any error message in log...

edit flag offensive delete link more
0

answered 2013-07-17 11:45:43 -0500

maoliping455 gravatar image

I think I have met the same issue before, you can check quantum dhcp log. If you find the log like following:

RuntimeError: Command: ['sudo', '/usr/bin/quantum-rootwrap', '/etc/quantum/rootwrap.conf', 'ip', 'link', 'set', 'qg-dd9483f7-7d', 'address', 'fa:16:3e:a9:07:58']Exit code: 2Stdout: ''Stderr: 'RTNETLINK answers: Device or resource busy\n'

You can solve this issue refer to the following URL: http://blog.csdn.net/maoliping455mlp455/article/details/9331375 (http://blog.csdn.net/maoliping455mlp4...)

edit flag offensive delete link more
0

answered 2013-07-18 18:34:09 -0500

ptc61891 gravatar image

I am running OStack without quantum installed

edit flag offensive delete link more
0

answered 2013-07-17 11:45:41 -0500

maoliping455 gravatar image

I think I have met the same issue before, you can check quantum dhcp log. If you find the log like following:

RuntimeError: Command: ['sudo', '/usr/bin/quantum-rootwrap', '/etc/quantum/rootwrap.conf', 'ip', 'link', 'set', 'qg-dd9483f7-7d', 'address', 'fa:16:3e:a9:07:58']Exit code: 2Stdout: ''Stderr: 'RTNETLINK answers: Device or resource busy\n'

You can solve this issue refer to the following URL: http://blog.csdn.net/maoliping455mlp455/article/details/9331375 (http://blog.csdn.net/maoliping455mlp4...)

edit flag offensive delete link more
0

answered 2013-07-17 11:45:39 -0500

maoliping455 gravatar image

I think I have met the same issue before, you can check quantum dhcp log. If you find the log like following:

RuntimeError: Command: ['sudo', '/usr/bin/quantum-rootwrap', '/etc/quantum/rootwrap.conf', 'ip', 'link', 'set', 'qg-dd9483f7-7d', 'address', 'fa:16:3e:a9:07:58']Exit code: 2Stdout: ''Stderr: 'RTNETLINK answers: Device or resource busy\n'

You can solve this issue refer to the following URL: http://blog.csdn.net/maoliping455mlp455/article/details/9331375 (http://blog.csdn.net/maoliping455mlp4...)

edit flag offensive delete link more
0

answered 2013-07-17 11:45:38 -0500

maoliping455 gravatar image

I think I have met the same issue before, you can check quantum dhcp log. If you find the log like following:

RuntimeError: Command: ['sudo', '/usr/bin/quantum-rootwrap', '/etc/quantum/rootwrap.conf', 'ip', 'link', 'set', 'qg-dd9483f7-7d', 'address', 'fa:16:3e:a9:07:58']Exit code: 2Stdout: ''Stderr: 'RTNETLINK answers: Device or resource busy\n'

You can solve this issue refer to the following URL: http://blog.csdn.net/maoliping455mlp455/article/details/9331375 (http://blog.csdn.net/maoliping455mlp4...)

edit flag offensive delete link more
0

answered 2013-07-18 18:34:10 -0500

ptc61891 gravatar image

I am running OStack without quantum installed

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-07-11 13:36:19 -0500

Seen: 85 times

Last updated: Jul 18 '13