Can't ping floating ip or Instances

asked 2020-05-23 17:24:13 -0500

bateman231 gravatar image

So ive been trying for like 2 months in my free time to try to connect to my VMs in Devstack, but whatever i do i simply can't connect from another machine in the same network, and simply can't ping them, here are some screenshots of what ive been trying.

Note: i have 2 network interfaces and so i'm assigning the public_interface to my sencond network interface https://imgur.com/LphvgQ4 (My local.conf credentials are only for testing porpuses)

https://imgur.com/Uku0Nsa (The ip addresses of the server)

https://imgur.com/MCBguQn (Security group rules)

https://imgur.com/CeL57OI (Floating ip)

https://imgur.com/aYcCpuJ (The instance i'm trying to connect)

https://imgur.com/SYV764V (The network topology)

https://imgur.com/fWNvkR2 (Example of when i try to ping the floating ip)

So any help in guiding me in what i could be missing would be really helpful

edit retag flag offensive close merge delete

Comments

I have never seen TTL expired in transit. It looks like the ICMP echo requests are bounced around.

To understand this better, I'd try traceroute FLOATING_IP. Perhaps the settings documented in https://docs.openstack.org/devstack/l... will help.

Bernd Bausch gravatar imageBernd Bausch ( 2020-05-23 20:02:34 -0500 )edit

Or remove the IP addresses from enp2s0. In any case, my hope is that the traceroute command will provide some insight.

Can you share the routing table, too?

Bernd Bausch gravatar imageBernd Bausch ( 2020-05-23 20:04:39 -0500 )edit

https://imgur.com/AjPT78V so the traceroute show this, also what do you mean by remove the IP address from enp2s0? as in remove the netplan file of the second interface and leave it by default?, also i'm aware of that page, thats why i added a second network interface, but still no luck

bateman231 gravatar imagebateman231 ( 2020-05-23 20:32:50 -0500 )edit

Your tracert output shows that you have no route from the Windows PC to 172.24.4.62. Traffic goes to your internet provider instead of the VM.

Fix that first. I don't know if the additional addresses on enp2s0 pose a problem.

Bernd Bausch gravatar imageBernd Bausch ( 2020-05-24 00:35:32 -0500 )edit

actually i'm at a loss... i have no idea on how to proceed, any suggestions on how to change the route?

bateman231 gravatar imagebateman231 ( 2020-05-24 17:32:53 -0500 )edit