How to resolve permission denied error at Preparing Servers when attempting to install Packstack

asked 2020-05-21 17:58:47 -0500

kryls gravatar image

Hi, I'm attempting to install Packstack on Centos 7, but it keeps throwing an error at the step 'Preparing Servers'. I've added my public rsa key to the server, but it's still an issue. I've installed the OpenStack Stein version. Any help would be appreciated. Thanks!

[cotadmin@controller ~]$ sudo packstack --answer-file /root/answers.txt --timeout=1500 | tee packstack-output.txt

Welcome to the Packstack setup utility

The installation log file is available at: /var/tmp/packstack/20200521-173727-TLERM1/openstack-setup.log

Installing:
Clean Up                                             [ DONE ]

Discovering ip protocol version                      [ DONE ]

Setting up ssh keys                                  [ DONE ]

Preparing servers                                 [ ERROR ]

ERROR : Failed to run remote script, stdout:
stderr: Warning: Permanently added '192.168.5.30' (ECDSA) to the list of known hosts.
Permission denied (publickey,gssapi-keyex,gssapi-with-mic).

Please check log file /var/tmp/packstack/20200521-173727-TLERM1/openstack-setup.log for more information
Additional information:
 * Parameter CONFIG_NEUTRON_L2_AGENT: You have chosen OVN Neutron backend. Note that this backend does not support the VPNaaS or FWaaS services. Geneve will be used as the encapsulation method for tenant networks

Here's the error log:

2020-05-21 17:37:28::INFO::shell::100::root:: [localhost] Executing script:
rm -rf /var/tmp/packstack/20200521-173727-TLERM1/manifests/*pp
2020-05-21 17:37:28::INFO::shell::100::root:: [localhost] Executing script:
mkdir -p ~/.ssh
chmod 500 ~/.ssh
grep 'ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQC/uE9qhrQofsDmf2Oxn7pBOh4/8fXCsLdrbzOuZgQJrw69gP/oOudl3CbhnifDzHJ0Vmw5rIK93t/orcshH5w2dINvVMD9jE2ZiikGLJ5EU3mgJXxB5oaGWzH//a5W03oukpqwRvh5uO21qaIEODvQzCjDvtJT0hqd0tsoyd3GCTzO7u63tVETgayafTkZ/TGlrqgqjgLHZCctwzzJlEAPMPISBquQBTWDmualR8dFHCZN/rSUJzQbUQySvZDi2AMDgvyZ/weqMpVlO8SITgLl2ZzXtjcglKENnx8wauNLs62umrsSUCYbMjiQ1T018bUBwcBOFYp3GRpGCG1dSR1P korey@DESKTOP-TB3RRQG' ~/.ssh/authorized_keys > /dev/null 2>&1 || echo ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQC/uE9qhrQofsDmf2Oxn7pBOh4/8fXCsLdrbzOuZgQJrw69gP/oOudl3CbhnifDzHJ0Vmw5rIK93t/orcshH5w2dINvVMD9jE2ZiikGLJ5EU3mgJXxB5oaGWzH//a5W03oukpqwRvh5uO21qaIEODvQzCjDvtJT0hqd0tsoyd3GCTzO7u63tVETgayafTkZ/TGlrqgqjgLHZCctwzzJlEAPMPISBquQBTWDmualR8dFHCZN/rSUJzQbUQySvZDi2AMDgvyZ/weqMpVlO8SITgLl2ZzXtjcglKENnx8wauNLs62umrsSUCYbMjiQ1T018bUBwcBOFYp3GRpGCG1dSR1P korey@DESKTOP-TB3RRQG >> ~/.ssh/authorized_keys

chmod 400 ~/.ssh/authorized_keys
restorecon -r ~/.ssh

2020-05-21 17:37:28::INFO::shell::100::root:: [192.168.5.30] 

Executing script:
rpm -q --whatprovides yum-utils || yum install -y yum-utils

2020-05-21 17:37:28::ERROR::run_setup::1062::root:: Traceback (most recent call last):

  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 1057, in main
    _main(options, confFile, logFile)

  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 681, in _main
    runSequences()

  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 648, in runSequences
    controller.runAllSequences()

  File "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py", line 81, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)

  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 109, in run
    step.run(config=config, messages=messages)

  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 50, in run
    self.function(config, messages)

  File "/usr/lib/python2.7/site-packages/packstack/plugins/prescript_000.py", line 1351, in server_prep
    server.execute()

  File "/usr/lib/python2.7/site-packages/packstack/installer/utils/shell.py", line 140, in execute
    raise ScriptRuntimeError(msg, stdout=out, stderr=err)

ScriptRuntimeError: Failed to run remote script, stdout:
stderr: Warning: Permanently added '192.168.5.30' (ECDSA) to the list of known hosts.^M

Permission denied (publickey,gssapi-keyex,gssapi-with-mic).^M
edit retag flag offensive close merge delete

Comments

What does your answer file look like, and which server is 192.168.5.30? Is it an all-in-one installation?

Do you also get the error when installing with default answers, i.e. sudo packstack --allinone?

This key korey@DESKTOP-TB3RRQG doesn't look right.

Bernd Bausch gravatar imageBernd Bausch ( 2020-05-21 22:32:41 -0500 )edit

Perhaps this is your scenario: https://ask.openstack.org/en/question.... Set PermitRootLogin no in the sshd_config file.

Bernd Bausch gravatar imageBernd Bausch ( 2020-05-21 22:34:21 -0500 )edit

Hi,It's not an all-in-one installation. I installed packstack with sudo yum install -y openstack-packstack . I'm able to ssh into the server with that public key. the PermitRootLogin was commented out. I set it to yes and then no but still same issue. Thanks for pointing me to that scenario tho.

kryls gravatar imagekryls ( 2020-05-22 08:25:36 -0500 )edit

According to https://www.rdoproject.org/install/ad...:

Packstack will prompt you for the root password for each of your nodes.

Did that happen? I wonder if the non-root user's key is the culprit. The above-mentioned page doesn't mention keys.

Bernd Bausch gravatar imageBernd Bausch ( 2020-05-22 09:14:28 -0500 )edit

Hi, no I wasn't prompted for any passwords just yet. It's possible the key is the issue. I initially thought the issue is because i'm using Stein Openstack instead of the latest. Maybe I could try wiping Packstack and reinstalling again.. Thanks for your help.

kryls gravatar imagekryls ( 2020-05-22 11:54:08 -0500 )edit