nova-api train - ubuntu 18.04 does not start

asked 2020-05-15 02:28:32 -0500

GabrieleB gravatar image

Hi all,

I'm trying to install a basic OpenStack train installation, following this guide: https://docs.openstack.org/install-guide/openstack-services.html (https://docs.openstack.org/install-gu...)

I am at the nova installation step, but for some reason, nova-api and nova-conductor are not starting. Here the journal log of both.

nova-api:

May 15 07:16:32 openstack-controller systemd[1]: Started OpenStack Compute API.
May 15 07:16:34 openstack-controller nova-api[18568]: /usr/lib/python3/dist-packages/paste/deploy/loadwsgi.py:22: PkgResourcesDeprecationWarning: Parameters to load are deprecated.  Call .resolve and .require separately.
May 15 07:16:34 openstack-controller nova-api[18568]:   return pkg_resources.EntryPoint.parse("x=" + s).load(False)
May 15 07:16:34 openstack-controller systemd[1]: nova-api.service: Main process exited, code=exited, status=1/FAILURE
May 15 07:16:35 openstack-controller systemd[1]: nova-api.service: Failed with result 'exit-code'.
May 15 07:16:35 openstack-controller systemd[1]: nova-api.service: Service hold-off time over, scheduling restart.
May 15 07:16:35 openstack-controller systemd[1]: nova-api.service: Scheduled restart job, restart counter is at 40.
May 15 07:16:35 openstack-controller systemd[1]: Stopped OpenStack Compute API.

That seems some sort of python related error.

nova-conductor:

May 15 07:24:49 openstack-controller systemd[1]: nova-conductor.service: Main process exited, code=exited, status=1/FAILURE
May 15 07:24:49 openstack-controller systemd[1]: nova-conductor.service: Failed with result 'exit-code'.
May 15 07:24:50 openstack-controller systemd[1]: nova-conductor.service: Service hold-off time over, scheduling restart.
May 15 07:24:50 openstack-controller systemd[1]: nova-conductor.service: Scheduled restart job, restart counter is at 29.
May 15 07:24:50 openstack-controller systemd[1]: Stopped OpenStack Compute Conductor.

But I guess it fails because he cannot connect to nova-api.

I'm running on:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.4 LTS"

nova-api --version
20.1.1

uname -a
Linux openstack-controller 4.15.0-99-generic #100-Ubuntu SMP Wed Apr 22 20:32:56 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Any suggestion?

edit retag flag offensive close merge delete

Comments

Check the Nova logs.

Bernd Bausch gravatar imageBernd Bausch ( 2020-05-15 17:29:03 -0500 )edit

Right....

It was a typo in the [vnc] section Thanks

GabrieleB gravatar imageGabrieleB ( 2020-05-16 09:13:17 -0500 )edit