Can't get ride on neutron error

asked 2020-05-11 11:06:07 -0500

JBIRO gravatar image

Parameter CONFIG_NEUTRON_L2_AGENT: You have chosen OVN Neutron backend. Note that this backend does not support the VPNaaS or FWaaS services. Geneve will be used as the encapsulation method for tenant networks.

used command : packstack --allinone --provision-demo=n --os-neutron-ovs-bridge-mappings=extnet:br-ex --os-neutronml2-type-drivers=vxlan,flat

edit retag flag offensive close merge delete

Comments

It's a warning, not an error. If you want to get rid of it, configure OVS. This is what I did: https://ask.openstack.org/en/question...

Bernd Bausch gravatar imageBernd Bausch ( 2020-05-11 17:11:48 -0500 )edit

but this warning cant make an issue to openstack work process ?

JBIRO gravatar imageJBIRO ( 2020-05-11 19:00:06 -0500 )edit

It affects VPNaaS and FWaaS. They can't be used.

Also, your option --os-neutron-ovs-bridge-mappings=extnet:br-ex only concerns Openvswitch and will have no effect, or it might even create a conflict.

Bernd Bausch gravatar imageBernd Bausch ( 2020-05-11 19:50:16 -0500 )edit

im not using vpnaas and fwaaas , but whats make no sense its when i configure answer file using ur solution (ML2 mechanism driver OVN instead of Openvswitch, and type driver Geneve instead of VXLAN) , i have same warrning and i cant access the dashboard !

JBIRO gravatar imageJBIRO ( 2020-05-11 21:01:24 -0500 )edit

My solution is to not use OVN.

Bernd Bausch gravatar imageBernd Bausch ( 2020-05-11 21:19:21 -0500 )edit