Ask Your Question
0

On Ubuntu 11.10, can't call nova-manage without ImportError SSLv2_method

asked 2011-10-31 22:39:16 -0500

robpneff gravatar image

Any call involving nova-manage returns the following traceback on Ubuntu 11.10.

Commands: $tar -xzvf M2Crypto-0.21.1.tar.gz $cd M2Crypto-0.21.1 $aptitude install swig libssl-dev python-dev $python setup.py build $python setup.py install

flexnova@cloudcontroller:~/M2Crypto-0.21.1$ sudo nova-manage user create admin mike Traceback (most recent call last): File "/usr/bin/nova-manage", line 80, in <module> from nova import crypto File "/usr/lib/python2.7/dist-packages/nova/crypto.py", line 36, in <module> import M2Crypto File "/usr/local/lib/python2.7/dist-packages/M2Crypto-0.21.1-py2.7-linux-x86_64.egg/M2Crypto/__init__.py", line 22, in <module> import __m2crypto ImportError: /usr/local/lib/python2.7/dist-packages/M2Crypto-0.21.1-py2.7-linux-x86_64.egg/M2Crypto/__m2crypto.so: undefined symbol: SSLv2_method

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2011-11-09 00:25:59 -0500

hhgzju gravatar image

Thank you very much ,but I still can't resolve the problem.Could you give me your detail document of installing OpenStack? If so ,Sent the document to my e-Mail:hhgzju@163.com. Thanks !

edit flag offensive delete link more
0

answered 2011-11-03 18:39:18 -0500

robpneff gravatar image

Turns out that installing M2Crypto-0.21.1.tar.gz caused the problem. .21.1 had a regression in it and by going by to the version that came with Ubuntu .20.1, nova-manage worked without problem.

edit flag offensive delete link more
0

answered 2011-11-08 13:31:31 -0500

hhgzju gravatar image

I getting the same problem with you :ImportError: /usr/local/lib/python2.7/dist-packages/M2Crypto-0.21.1-py2.7-linux-x86_64.egg/M2Crypto/__m2crypto.so: undefined symbol: SSLv2_method. How did you resove it?

edit flag offensive delete link more
0

answered 2011-11-08 18:25:33 -0500

robpneff gravatar image

I deleted this file. /usr/local/lib/python2.7/dist-packages/M2Crypto-0.21.1-py2.7-linux-x86_64.egg

Then I did an apt-get M2Crypto and Ubuntu installed vs 20.1.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-10-31 22:39:16 -0500

Seen: 50 times

Last updated: Nov 09 '11