Ask Your Question

Ironic problem when provide node

asked 2020-04-27 17:19:23 -0600

NicodemosPapadoulos gravatar image

Hi friends,

I am experiencing a problem with ironic. When I try to put my recently created node in provide mode the process fails. The openstack baremetal node show $NODE_UUID shows the provision_state as clean failed.

The last_error field shows:

Failed to prepare node c43b5ed4-2de1-4f4c-88b0-4c07a1f97b42 for cleaning: Failed to create neutron ports for node's c43b5ed4-2de1-4f4c-88b0-4c07a1f97b42 ports [Port(address=XX:XX:XX:XX:XX:XX,created_at=2020-04-27T01:10:27Z,extra={},id=3,internal_info={},is_smartnic=False,local_link_connection={},node_id=1,physical_network='provider',portgroup_id=None,pxe_enabled=True,updated_at=None,uuid=eed43ccc-3dd8-47e6-aa32-6f96db99ec42)].

The ironic is capable of working with ML2 linuxbridge mechanism? I ask this because the ironic documentation shows OVS as ML2 mechanism. My ML2 mechanism driver is linuxbridge. Maybe this be the cause of the problem?

My config files:

  1. ml2_conf.ini: (
  2. ironic.conf: (
  3. ironic_neutron_agent.ini: (

The log files:

  1. ironic-api.log: (
  2. ironic-conductor.log: (
  3. ironic-neutron-agent.log: (

My environment: Openstack Train Ubuntu server 18.04

Thank you very much.

PS: this a new baremetal installation and I am not a specialist in the topic. This can be an error of mine and I apologize if that is the case.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2020-05-28 00:31:58 -0600

ahabib gravatar image

updated 2020-06-09 09:38:10 -0600

I'm having same error with OVS with managing a baremetal node with IPMI driver server model hp dl380 g7 with mac address and IP of ILO management port set for the node info

Failed to prepare node 6a4df57c-830c-4442-8788-320238b5fc8b for cleaning: Failed to create neutron ports for node's 6a4df57c-830c-4442-8788-320238b5fc8b ports [Port(address=68:b5:99:70:2b:f4,created_at=2020-05-18T09:21:40Z,extra={},id=1,internal_info={},is_smartnic=False,local_link_connection={},node_id=1,physical_network=None,portgroup_id=None,pxe_enabled=True,updated_at=None,uuid=11aba7e1-cb78-4e71-ba37-7a97331fb47a)].

UPDATE: i was able to solve this by changing port type to flat !

any help is appreciated. Thanks in advance

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2020-04-27 17:19:23 -0600

Seen: 102 times

Last updated: Jun 09 '20