Unable to retreive image info from glance: Invalid service catalog service: image (HTTP 404)

asked 2012-02-03 03:54:02 -0600

weissa gravatar image

Hey guys,

I'm having an issue upon logging in to the Dashboard and navigating to the "Images" page as follows:

"Unable to retreive image info from glance: Invalid service catalog service: image (HTTP 404)"

I have verified that all of my services are running and that I successfully list the stored images by using the command:

glance index -A <token> --host=<glanceip>

The Dashboard also indicates that the "image-service" service is "Enabled" and "Up". Let me know if you would like me to post any of my configs.

Thanks, Andrew

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2012-02-03 15:31:27 -0600

Hi,

Hi, I have no experiences with python, so I'm not sure if this is proper fix but here is how I fixed my dashboard. Problem is, that dashboard is addressing glance service as "image" but it should be "image-service"

So this workaround fixed for me:

open "horizon/api/glance.py" where ever is your dashboard installed and search for this line (line 54 in my installation):

o = urlparse.urlparse(url_for(request, 'image'))

and replace image with image-service like this:

o = urlparse.urlparse(url_for(request, 'image-service'))

than restart dashboard

edit flag offensive delete link more
0

answered 2012-02-03 18:21:55 -0600

weissa gravatar image

Thank you so much! This resolved the issue.

edit flag offensive delete link more
0

answered 2012-02-08 16:29:59 -0600

kiall gravatar image

The service name for glance is "image", not "image-service".

The correct fix for this is to update the name from "image-service" to "image" in keystone.

edit flag offensive delete link more
0

answered 2012-02-24 03:52:02 -0600

shounak-acharya gravatar image

Hi Kiall,

How do you update the name in keystone from image-service to image. I have added the service endpoint for glance in keystone with the following command and as far as I can see it is image and not image-service and I am still facing the same problem as Andrew.

sudo bin/keystone-manage service add glance image "OpenStack Image Service"

Thanks

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-02-03 03:54:02 -0600

Seen: 250 times

Last updated: Feb 24 '12