Error while issuing "nova network-create" command on controller

asked 2014-03-01 07:16:23 -0600

GautamSomani gravatar image

I am following the openstack docs to create a simple cloud on ubuntu machines. While following "Enable Networking" section, I gave the command:

nova network-create vmnet --fixed-range-v4=10.0.2.0/24 --bridge-interface=br100 --multi-host=T

on the controller node and got the following message errror on the commandline itself:

ERROR: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-294175e5-51eb-460e-bd01-fea5e70d6233)

On checking the NOVA logs on the controller machine, I found the following errors in nova-api.log file:

2014-03-01 18:26:53.199 7385 INFO nova.osapi_compute.wsgi.server [-] (7385) accepted ('127.0.0.1', 44627)

2014-03-01 18:27:53.267 7385 ERROR nova.api.openstack [req-294175e5-51eb-460e-bd01-fea5e70d6233 06060c0a6949485c890554811a8029fc f66500725dd34ea09d1a0a645680dfb8] Caught error: Timeout while waiting on RPC response - topic: "network", RPC method: "create_networks" info: "<unknown>"
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack Traceback (most recent call last):
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/nova/api/openstack/__init__.py", line 119, in __call__
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack     return req.get_response(self.application)
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/webob/request.py", line 1296, in send
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack     application, catch_exc_info=False)
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/webob/request.py", line 1260, in call_application
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack     app_iter = application(self.environ, start_response)
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/webob/dec.py", line 144, in __call__
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack     return resp(environ, start_response)
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/keystoneclient/middleware/auth_token.py", line 539, in __call__
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack     return self.app(env, start_response)
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/webob/dec.py", line 144, in __call__
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack     return resp(environ, start_response)
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/webob/dec.py", line 144, in __call__
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack     return resp(environ, start_response)
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/routes/middleware.py", line 131, in __call__
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack     response = self.app(environ, start_response)
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/webob/dec.py", line 144, in __call__
 2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack     return resp(environ, start_response)
2014-03-01 18:27:53.267 7385 TRACE nova.api.openstack   File "/usr/lib/python2 ...
(more)
edit retag flag offensive close merge delete

Comments

Check you rabbitmq is running. If you are sure that all the processes are running fine, it must be some configuration issue only. Check your networking configuration. Check that all the configurations are in appropriate section like [Ddefault] or [database] etc.

dheeru gravatar imagedheeru ( 2014-03-02 01:26:34 -0600 )edit

What version of openstack? Is it nova-network backed or have you enabled quantum/neutron? Usually "Timeout while waiting on RPC response " means nova wasn't able to find or talk to some underlying system (like neutron).

Joseph Kubik gravatar imageJoseph Kubik ( 2014-03-06 08:31:18 -0600 )edit

I am also having this problem with nova-network: http://hastebin.com/ibuzuxewaf.vhdl

RabbitMQ seems to be running fine: http://hastebin.com/episadegox.tex

My config file looks like this: http://hastebin.com/raw/dacowasaxe

I also change the rpc_backend to nova.rpc.impl_kombu but it didn't do it.

bogdan gravatar imagebogdan ( 2014-04-30 06:31:01 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-05-02 02:11:43 -0600

bogdan gravatar image

There are two issues:

  1. nova-network is not started
  2. The command for adding the network is nova network-create demo-net --bridge-interface=enp5s0 --bridge br100 --multi-host T --fixed-range-v4 10.0.2.0/24
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-01 07:16:23 -0600

Seen: 851 times

Last updated: May 02 '14