nova-compute not appearing on controller node

asked 2020-04-10 00:30:09 -0500

anonymous user

Anonymous

Running "openstack compute service list --service nova-compute" (as shown in https://docs.openstack.org/nova/stein/install/compute-install-ubuntu.html (here) ) on the controller node, it does not display nova-compute. I've seen a couple other posts similar to this issue; however, most seemed to be from typo issues in the configuration files. I have triple checked all of them, especially transport_url in /etc/nova/nova.conf and everything seems fine (I did all of configuration as in installation guide from the previous link). When I run "openstack compute service list" I can only see nova-scheduler, nova-conductor, and nova-consoleauth enabled.

I checked /var/log/nova/nova-compute.log on the compute node and I do have some errors:

ERROR nova keystoneauth1.exceptions.auth plugin.MissingRequiredOptions: Auth plugin requires parameters which were not give: auth_url

I also checked /var/log/rabbitmq/rabbit\@controller.log and I have many warnings that I'm not sure about but may be related. My controller node is 10.0.0.11 and my compute node is 10.0.0.31. The warning says:

closing AMQP connection <0.1384.2> (10.0.0.31:49826 -> 10.0.0.11:5672 - nova-compute:29373:86eda44f ... ee6, vhost: '/', user: 'openstack'): client unexpectedly closed TCP connection

Also, host_mappings table in nova_api database is empty and the table returned from "nova-manage cell_v2 list_hosts" is also empty even after running 'su -s /bin/sh -c "nova-manage cell_v2 discover_hosts --verbose" nova'

How I might resolve this issue?

edit retag flag offensive close merge delete

Comments

Auth plugin requires parameters which were not give: auth_url

To me, this looks like you failed to set the auth_url parameter, and nova-compute expects it.

Now you say you double-checked everything. I am not sure but I believe that DEBUG logging lists all parameters that you set. Worth a try.

Bernd Bausch gravatar imageBernd Bausch ( 2020-04-10 00:51:58 -0500 )edit

I set debug = true in nova.conf on the compute node. I ran the same command on the controller and looked at nova-compute.log on the compute node and didn't any mention of the parameters in the debugging. I have auth_url set in [keystone_authtoken] section of nova.conf on the compute node.

mtruong1999 gravatar imagemtruong1999 ( 2020-04-10 01:31:44 -0500 )edit

"auth_url = http://controller:5000/v3%22 (http://controller:5000/v3") is what I set.

mtruong1999 gravatar imagemtruong1999 ( 2020-04-10 01:32:30 -0500 )edit