Ask Your Question
0

Failed to discover available identity versions when trying to create Keystone domain

asked 2020-04-04 16:05:01 -0500

mtruong1999 gravatar image

Hi all,

I have been following the manual deployment guide for OpenStack Stein on Ubuntu Server 18.04 using VirtualBox VM (https://docs.openstack.org/keystone/train/install/keystone-users-ubuntu.html (Here's) a link of where I'm currently at in the process, as of now I have installed keystone and properly configured everything as described in the installation guide). However, when trying to execute 'openstack domain create --description "An example domain" example I get the following error:

Failed to discover available identity versions when contacting http://controller:5000/v3. Attempting to parse version from URL. Unable to establish connection to http://controller:5000/v3/auth/tokens: HTTPConnectionPool(host='controller',port=5000): Max retries exceeded with url: /v3/auth/tokens (Caused by NewConnectionError(',<urllib3.connection.httpconnection 0x7f675fb52c18="" at="" object="">: Failed to establish a new connection: [Errno 111] Connection refused',))</urllib3.connection.httpconnection>

I've triple checked all configuration files and environment variables exported, and checked that all services were running (i.e. rabbitmq, apache2, etcd, memcached, and chrony) to make sure everything is correct as in the installation guide, I've had no problems up till now. I've tried searching many resources trying to figure out this issue, but was unsuccessful. This is all new to me and I would appreciate it if anyone provided some insight/solution for the issue I am facing.

edit retag flag offensive close merge delete

Comments

1

If http://controller:5000/v3 can't be reached, either the name controller doesn't resolve correctly, or Apache isn't listening at port 5000.

The URL might be incorrect. Try curl http://controller/identity/v3.

Bernd Bausch gravatar imageBernd Bausch ( 2020-04-04 18:41:00 -0500 )edit

Thank you for your response. curl http://controller/identity/v3 command returns 404 Not Found in html title, with "The requested URL was not found on this server" in paragraph body, and "Apache/2.4.29 (Ubuntu) Server at controller Port 80" enclosed in an address tag.

mtruong1999 gravatar imagemtruong1999 ( 2020-04-04 18:55:21 -0500 )edit
1

Find out on which port(s) Apache is listening. Use ss -lntp or netstat -lntp.

I haven't gone through the installation tutorial for a long while, but I think that ports are normally not used in endpoints anymore. Try without the v3: curl http://controller/identity.

Bernd Bausch gravatar imageBernd Bausch ( 2020-04-04 23:25:00 -0500 )edit

Running netstat -lntp tells me apache is listening on port 80, I found /etc/apache2/ports.conf, do you know if that is the appropriate place to change the port to 5000? (The curl command without v3 returns the same thing)

mtruong1999 gravatar imagemtruong1999 ( 2020-04-04 23:39:59 -0500 )edit

So I tried changing /etc/apache2/sites-enabled/000-default.conf and /etc/apache2/ports.conf to Listen on 5000 and ran the openstack command. This time I got "Failed to discover available identity versions when contacting http://controller:5000/v3. Attempting to parse version from URL. Not Found

mtruong1999 gravatar imagemtruong1999 ( 2020-04-05 00:30:23 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2020-04-07 15:35:49 -0500

mtruong1999 gravatar image

Problem was solved by uninstalling and reinstalling keystone packages. Something must have gone wack-o in the initial installation.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2020-04-04 16:00:48 -0500

Seen: 135 times

Last updated: Apr 04