after installation of devstack the dashboard is forbidden

asked 2020-04-01 05:30:41 -0600

eltaccabro gravatar image

I install devstack on an laptop with ubuntu 18.04 with static local ip address 192.168.1.240. this is the log after the devstack installation

This is your host IP address: 192.168.1.240
This is your host IPv6 address: ::1
Horizon is now available at http://192.168.1.240/dashboard
Keystone is serving at http://192.168.1.240/identity/
The default users are: admin and demo
The password: openstack

WARNING: 
Using lib/neutron-legacy is deprecated, and it will be removed in the future


Services are running under systemd unit files.
For more information see: 
https://docs.openstack.org/devstack/latest/systemd.html

DevStack Version: ussuri
Change: be26306b23ab470e65cc93305453d2945aa33bf78 Support extras in Glance Store install 2020-03-30 19:53:32 +0200
OS Version: Ubuntu 18.04 bionic

and this is my local.conf:

[[local|localrc]]
LOGFILE=/opt/stack/logs/stack.sh.log
disable_service etcd3
FLOATING_RANGE=192.168.1.241/27
FIXED_RANGE=10.11.12.0/24
ADMIN_PASSWORD=openstack
DATABASE_PASSWORD=openstack
RABBIT_PASSWORD=openstack
SERVICE_PASSWORD=openstack

but on the dashboard address I get this error:

Forbidden

You don't have permission to access this resource. Apache/2.4.29 (Ubuntu) Server at 192.168.1.240 Port 80

i also change the last row on the file local_settings.py on /opt/stack/horizon/openstack_dashboard/local

form ALLOWED_HOSTS=["*"] to ALLOWED_HOSTS=["192.168.1.240"] and restart apache2 service, but the error is the same.

any ideas on how I can solve this problem and access on the dashboard I can't find anything on forum?

edit retag flag offensive close merge delete

Comments

The first thing to do, always, is reading the logs. In this case, I would recommend to start with the Apache logs.

Bernd Bausch gravatar imageBernd Bausch ( 2020-04-01 21:13:31 -0600 )edit

ok thanks... the problem is on permission: 2020-04-02 11:51:35.501051 AH00035: access to /dashboard/ denied (filesystem path '/opt/stack/horizon') because search permissions are missing on a component of the path

but... in which file i have to put the right permissions?

eltaccabro gravatar imageeltaccabro ( 2020-04-02 05:06:13 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2020-04-07 05:12:36 -0600

eltaccabro gravatar image

on /var/log/apache2/error.log i got this:

[Tue Apr 07 11:53:13.273952 2020] [mpm_event:notice] [pid 9093:tid 140685633723328] AH00491: caught SIGTERM, shutting down
[Tue Apr 07 11:53:13.364260 2020] [ssl:warn] [pid 9453:tid 140514728565696] AH01906: 127.0.1.1:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Apr 07 11:53:13.364301 2020] [ssl:warn] [pid 9453:tid 140514728565696] AH01909: 127.0.1.1:443:0 server certificate does NOT include an ID which matches the server name
[Tue Apr 07 11:53:13.381432 2020] [mpm_event:notice] [pid 9454:tid 140514728565696] AH00489: Apache/2.4.29 (Ubuntu) OpenSSL/1.1.1e mod_wsgi/4.5.17 Python/3.6 configured -- resuming normal operations
[Tue Apr 07 11:53:13.381499 2020] [core:notice] [pid 9454:tid 140514728565696] AH00094: Command line: '/usr/sbin/apache2'

on /etc/apache2/sites-available/000-default.conf

i Set up apache ServerName as localhost, but nothing change

can you help me please? thank you

edit flag offensive delete link more

Comments

Are you sure the two errors are related? They don't seem to be.

By the way, the second error doesn't look like an error. Just a warning that TLS won't work. OpenStack works nicely without TLS.

Bernd Bausch gravatar imageBernd Bausch ( 2020-04-07 07:09:59 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2020-04-01 05:30:41 -0600

Seen: 208 times

Last updated: Apr 01