Cannot set new URL for VNC end client

asked 2020-03-23 18:00:11 -0600

qumulus gravatar image

In my Train configuration, I'm trying to set up VNC access with TLS. My CA-signed certificate has my organization's URL baked in. I set the following in nova.conf:

 novncproxy_base_url = https://my.custom.url.com:6080/vnc_auto.html

Then I restarted the services:

service nova-api restart
service nova-novncproxy restart
service apache2 restart

However, when I accessed the VNC console page on Horizon, the URL is not the one I just set. I then checked the log (after setting debug = True), and saw that the URL was set. From nova-api.log:

2020-03-23 18:39:01.712 1670 DEBUG oslo_service.service [-] vnc.novncproxy_base_url        = https://my.custom.url.com:6080/vnc_auto.html log_opt_values /usr/lib/python3/dist-packages/oslo_config/cfg.py:2585

Why isn't my new URL used in the end-client browser, even though the log shows that the new URL was set in the config?

edit retag flag offensive close merge delete

Comments

1

Have you tried from the compute

$ openstack console url show provider-instance

In my case the result didn't work either. But the instance was running and can be reached by ssh

tjoen gravatar imagetjoen ( 2020-03-25 14:31:34 -0600 )edit

I fixed the problem! I was changing the configuration in the controller node and restarting the services there. Instead, you have to edit the config in the compute node and restart the services there!

qumulus gravatar imagequmulus ( 2020-03-26 11:44:41 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2020-03-26 11:47:35 -0600

qumulus gravatar image

Fixed the problem. Change the novncproxy_base_url value in nova.conf in the compute/hypervisor node and restart nova-compute in the hypervisor node.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2020-03-23 17:56:50 -0600

Seen: 101 times

Last updated: Mar 23 '20