An unexpected error has occurred. Try refreshing the page. If that doesn't help, contact your local administrator.

asked 2014-02-28 07:22:43 -0600

Sathish gravatar image

Hi,

I'm new to OpenStack and I have followed http://openstack.redhat.com/Quickstart link and installed it in single machine. ( 4GB RAM, Intel i5 processor 4 core CPU) and after completely installing it. I can able to login into the dashboard and access all the options/links in it except "Resource Usage" under "Admin" tab. When click the "Resource Usage"(http://192.168.1.231/dashboard/admin/metering/) It is displaying " Something went wrong! An unexpected error has occurred. Try refreshing the page. If that doesn't help, contact your local administrator." message.

I don't know how to fix it and the log file displays the appropriate logs. Could someone help me on this ?

Please let me know if you need any other details re this.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2014-02-28 07:34:38 -0600

Anand TS gravatar image

Hi Satheesh,

Check horizon logs and httpd/error_log

try to restart httpd services.

Anand

edit flag offensive delete link more

Comments

Thanks! I have checked httpd error, access and horizon logs. In access log 192.168.1.22 - - [28/Feb/2014:19:34:34 +0530] "GET /dashboard/admin/metering/ HTTP/1.1" 500 812 "http://192.168.1.231/dashboard/admin/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.160 Safari/537.22" In error log [Fri Feb 28 18:56:54 2014] [warn] [client 192.168.1.22] incomplete redirection target of '/dashboard/' for URI '/' modified to 'http://192.168.1.231/dashboard/', referer: http://192.168.1.231/dashboard/admin/metering/ In horizon log CommunicationError: Error communicating with http://192.168.1.231:8777 [Errno 111] Connection refused also I paste the entire bug here : http://pastebin.com/ynhDWHrq What could be the problem ? Did I missed anything? Please let me know.

Sathish gravatar imageSathish ( 2014-02-28 08:08:43 -0600 )edit
0

answered 2014-03-02 21:55:18 -0600

ZhiQiang Fan gravatar image

you need to check if ceilometer-api service is running on your server

try to run ps aux | grep ceilometer-api to check it if it is not running, try to run service openstack-ceilometer-api start to start it

you need to check /var/log/ceilometer/ceilometer-api.log (the basename can be different, for i.e. just api.log) and search anything unusal (level WARN and ERROR) to locate the root problem.

edit flag offensive delete link more

Comments

Thanks for your inputs! I have checked the ceilometer-api and its not running also when I tried to start it, the process gets terminated due to the absence of mongodb. So I have checked the status of mongodb. It was dead and also I couldn't start it. Please see here : http://pastebin.com/1xBCzj3U%3C/p%3E (http://pastebin.com/1xBCzj3U)

Sathish gravatar imageSathish ( 2014-03-03 05:06:23 -0600 )edit

root@server ~]# /etc/init.d/openstack-ceilometer-api start Starting openstack-ceilometer-api: [ OK ] [root@server ~]# /etc/init.d/openstack-ceilometer-api status openstack-ceilometer-api dead but pid file exists [root@server ~]# /etc/init.d/mongod status mongod dead but pid file exists [root@server ~]# /etc/init.d/mongod start Starting mongod: [ OK ] [root@server ~]# /etc/init.d/mongod status mongod dead but pid file exists Mongo db log Mon Mar 3 21:55:43.946 versionArrayTest passed Mon Mar 3 21:55:43.946 BackgroundJob starting: DataFileSync Mon Mar 3 21:55:43.947 shardKeyTest passed Mon Mar 3 21:55:43.947 isInRangeTest passed Mon Mar 3 21:55:43.947 shardObjTest passed Mon Mar 3 21:55:43.948 Invalid access at address: 0 from thread: Mon Mar 3 21:55:43.949 Got signal: 11 (Segmentation fault). Mon Mar 3 21:55:43.964 Backtrace: 0xa937a6 0x57af4d 0x57b2b7 0x3d7ce0f4a0 /usr/bin/mongod(_Z

Sathish gravatar imageSathish ( 2014-03-03 05:59:52 -0600 )edit
0

answered 2014-02-28 08:44:50 -0600

foexle gravatar image

Hi Sthish,

ceilometer is missing. http://192.168.1.231:8777 [Errno 111] Connection refused

Cheers Heiko

edit flag offensive delete link more

Comments

Thanks foexle! As like you said ceilometer api is dead and I couldn't start it. Please see here : http://pastebin.com/1xBCzj3U%3C/p%3E (http://pastebin.com/1xBCzj3U)

Sathish gravatar imageSathish ( 2014-03-03 05:07:42 -0600 )edit

You know the problem :). Whats our question, it's mongodb releated, so make mongodb running; set right creds, lets connect ceilometer and it works. Otherwhise you don't need for the first testing steps ceilometer, so you can disable it and if all other works re enable it again. Cheers

foexle gravatar imagefoexle ( 2014-03-07 03:47:03 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-02-28 07:22:43 -0600

Seen: 8,357 times

Last updated: Mar 02 '14