Qos policy doesn't work with floatingip [closed]

asked 2020-03-04 02:46:25 -0500

mr-han gravatar image

I applied the qos policy to VM port and it worked , but applied the qos policy to FIP port and it doesn't work

Is this normal ?

1. openstack port set   --qos-policy  qos-policy  FIP_PORT
2. neutron  floatingip-associate  FLOATINGIP_ID   VM_PORT
edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by mr-han
close date 2020-03-21 03:59:29.035534

1 answer

Sort by » oldest newest most voted
0

answered 2020-03-05 05:33:39 -0500

Hi,

To use QoS for Floating IPs, You need to enable "fip_qos" L3 agent extension and then associate QoS policy with the FIP, not with the port. After that bw limit should be set in the qrouter- namespace for the FIP. See https://docs.openstack.org/neutron/la... for details

edit flag offensive delete link more

Comments

Thanks, I solved the problem according to your suggestion

mr-han gravatar imagemr-han ( 2020-08-20 01:47:29 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2020-03-04 02:46:25 -0500

Seen: 117 times

Last updated: Mar 05