Ask Your Question
0

glance scrubber error log

asked 2020-03-02 08:51:31 -0500

M Rizqi Alfian gravatar image

i'm currently install manual openstack rocky in Opensuse Leap 15.1. i get this error when i try run this command "tail -f /var/log/glance/*", does it need to be fixed or just ignore the log ? because i think glance is running normally.

2020-03-02 21:15:53.262 21088 ERROR glance   File "/usr/bin/glance-scrubber", line 10, in <module>
    2020-03-02 21:15:53.262 21088 ERROR glance     sys.exit(main())
    2020-03-02 21:15:53.262 21088 ERROR glance   File "/usr/lib/python2.7/site-packages/glance/cmd/scrubber.py", line 113, in main
    2020-03-02 21:15:53.262 21088 ERROR glance     app.run()
    2020-03-02 21:15:53.262 21088 ERROR glance   File "/usr/lib/python2.7/site-packages/glance/scrubber.py", line 351, in run
    2020-03-02 21:15:53.262 21088 ERROR glance     delete_jobs = self._get_delete_jobs()
    2020-03-02 21:15:53.262 21088 ERROR glance   File "/usr/lib/python2.7/site-packages/glance/scrubber.py", line 333, in _get_delete_jobs
    2020-03-02 21:15:53.262 21088 ERROR glance     raise exception.FailedToGetScrubberJobs()
    2020-03-02 21:15:53.262 21088 ERROR glance FailedToGetScrubberJobs: Scrubber encountered an error while trying to fetch scrub jobs.
    2020-03-02 21:15:53.262 21088 ERROR glance
edit retag flag offensive close merge delete

Comments

did you configure the scrubber service? I think it’s /etc/glance/glance-scrubber.conf. If I remember correctly it’s just a cron job so if you don’t need it just deactivate the cronjob.

eblock gravatar imageeblock ( 2020-03-03 03:15:37 -0500 )edit

i'm not configuring scrubber service. i just configure glance api and glance registry. how to disable this ?

M Rizqi Alfian gravatar imageM Rizqi Alfian ( 2020-03-03 17:57:44 -0500 )edit

1 answer

Sort by » oldest newest most voted
1

answered 2020-03-04 13:53:33 -0500

eblock gravatar image

updated 2020-03-04 13:55:00 -0500

In my Ocata and Rocky environment (based on openSUSE) there's a cronjob to run glance-scrubber:

control1:~ # cat /etc/cron.hourly/openstack-glance-scrubber.cron 
#!/bin/sh

su glance -s /bin/sh -c "/usr/bin/glance-scrubber" || :

As this is on openSUSE systems it may be different in your environment. To disable it you can either uncomment the command or (re)move the cron file.

edit flag offensive delete link more

Comments

oke thanks.

M Rizqi Alfian gravatar imageM Rizqi Alfian ( 2020-03-06 02:03:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2020-03-02 08:51:31 -0500

Seen: 74 times

Last updated: Mar 04