allowed-ip-address pair in heat-template gives an error for CIDR validation

asked 2020-02-28 03:56:13 -0600

Nabin gravatar image

updated 2020-03-01 22:39:57 -0600

Using heat I am not able to set the ip address for allowed-ip-address pair. It gives an error stating its not a valid ip address and it should be in CIDR format.

ERROR: Property error: : resources.load_balancer_0_port.properties.allowed_address_pairs[0].ip_address: : Error validating value '10.10.10.10': '10.10.10.10' isn't a recognized IP subnet cidr, '10.10.10.10/32' is recommended

What changes need to be done to allow ip address ( without cidr ) for allowed-ip-address pair ?

edit retag flag offensive close merge delete

Comments

This was a known issue in Rocky release as i remember. How did you installed the openstack?

Mohit gravatar imageMohit ( 2020-02-28 09:05:39 -0600 )edit

I have installed using packstack. I am able to provide/update ip address from UI, but not through heat template.

Nabin gravatar imageNabin ( 2020-03-01 00:37:04 -0600 )edit