Ask Your Question
0

Failed to populate Neutron database ( Train)

asked 2020-02-17 20:53:48 -0500

quanlm gravatar image

I have follow exactly the Openstack install guide on the Docs

So far so good

I only occur a problems when populate the Neutron database:

After su -s /bin/sh -c "neutron-db-manage --config-file /etc/neutron/neutron.conf \ --config-file /etc/neutron/plugins/ml2/ml2_conf.ini upgrade head" neutron

I run for a while then this problem happended: oslo_db.exception.DBError: (pymysql.err.InternalError) (1832, "Cannot change column 'network_id': used in a foreign key constraint 'subnets_ibfk_1'") [SQL: 'ALTER TABLE subnets MODIFY network_id VARCHAR(36) NOT NULL'] (Background on this error at: http://sqlalche.me/e/2j85)

I have search on google but too few result found and didn't have anything at all

edit retag flag offensive close merge delete

Comments

What did you do when the error occurred?

Bernd Bausch gravatar imageBernd Bausch ( 2020-02-17 22:16:29 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2020-02-19 02:00:18 -0500

I think this is the same issue like https://bugs.launchpad.net/neutron/+b... and it can be "workarounded" by installing newer Mariadb version, like 10.4

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2020-02-17 20:53:48 -0500

Seen: 123 times

Last updated: Feb 19