Ask Your Question
0

Error: Systemd start for httpd failed!

asked 2020-01-24 18:04:23 -0500

Sheik gravatar image

updated 2020-01-24 20:56:12 -0500

packstack stein install fails with above error.

/var/log/httpd/error_log

[Fri Jan 24 18:52:43.659639 2020] [core:crit] [pid 12046] (22)Invalid argument: AH00069: make_sock: for address [::]:5000, apr_socket_opt_set: (IPV6_V6ONLY)
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:5000
[Fri Jan 24 18:52:43.659669 2020] [mpm_prefork:alert] [pid 12046] no listening sockets available, shutting down

If I change /etc/httpd/conf/ports.conf "Listen 5000" to another port "5099" Then, I can then start httpd

Reinstall then creates this file with port 5000 and packstack fails again.

Any ideas? Paul

journalctl -u httpd.service

Jan 24 21:46:35 openstack-master-burl python2[18636]: ERROR:scss.ast:Function not found: function-exists:1 Jan 24 21:46:35 openstack-master-burl python2[18636]: ERROR:scss.ast:Function not found: function-exists:1 Jan 24 21:46:35 openstack-master-burl python2[18636]: ERROR:scss.ast:Function not found: function-exists:1 Jan 24 21:46:44 openstack-master-burl systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE Jan 24 21:46:44 openstack-master-burl systemd[1]: httpd.service: control process exited, code=exited status=1 Jan 24 21:46:44 openstack-master-burl systemd[1]: Failed to start The Apache HTTP Server. Jan 24 21:46:44 openstack-master-burl systemd[1]: Unit httpd.service entered failed state. Jan 24 21:46:44 openstack-master-burl systemd[1]: httpd.service failed.

edit retag flag offensive close merge delete

Comments

You could use netstat or ss to check what is using port 5000, e.g. ss -ltnp | grep 5000.

Bernd Bausch gravatar imageBernd Bausch ( 2020-01-24 19:17:58 -0500 )edit

shows nothing.

master-burl ~]# ss -ltnp | grep 5000 master-burl ~]#

Sheik gravatar imageSheik ( 2020-01-24 20:25:51 -0500 )edit

I used a slightly different answer file and packstack completes but httpd still won't start.

I will paste journal output above.

Sheik gravatar imageSheik ( 2020-01-24 20:55:32 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2020-01-26 15:30:50 -0500

Sheik gravatar image

Not sure what solved this problem but it is gone now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2020-01-24 18:04:23 -0500

Seen: 171 times

Last updated: Jan 26