Ask Your Question
0

How to overcome 'Missing value auth-url required for auth plugin password'?

asked 2020-01-22 05:43:16 -0500

phanidutt gravatar image

I had followed the installation steps to install keystone service. But after providing the environment variable settings running the below command: { openstack domain create --description "An Example Domain" example } its just printing {Missing value auth-url required for auth plugin password' }

edit retag flag offensive close merge delete

Comments

My guess is that you did NOT provide the environment variables, in particular OS_AUTH_URL. Run export | grep OS_ to see the environment passed to the openstack command.

Bernd Bausch gravatar imageBernd Bausch ( 2020-01-22 07:56:19 -0500 )edit

Hey I tried that one it's showing OS_AUTH_URL as http://controller:5000/v3 .That is what I have given in keystone_admin file

phanidutt gravatar imagephanidutt ( 2020-01-22 09:45:50 -0500 )edit

This is strange. Try openstack --os-auth-url http://controller:5000/v3 domain create example.

Bernd Bausch gravatar imageBernd Bausch ( 2020-01-22 15:59:11 -0500 )edit

@Bernd While running above command as {sudo openstack --os-auth-url http://controller:5000/v3 domain create example} its asking for password while providing password its showing Missing parameter(s):Set a username with --os-username,OS_USERNAME.But while trying export | grep OS_ itsshowing variable

phanidutt gravatar imagephanidutt ( 2020-01-22 21:55:23 -0500 )edit

Hey we have changed the port for auth url, still we are facing the problem.We are using {sudo openstack --os-auth-url http://controller:4242/v3 domain create example} but without sudo it is having connection refused error. We have firewall and IPtables are enabled and 5000,35357 are blocked.

phanidutt gravatar imagephanidutt ( 2020-01-22 22:41:53 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2020-04-08 21:41:51 -0500

Hi is there who solved this ? after asking the missing value, I passed it as an argument to the command and here is the result.: sudo openstack --os-auth-url http://controller:5000/v3 --os-username=admin domain create example.

The error I have Password: Expecting to find domain in user. The server could not comply with the request since it is either malformed or otherwise incorrect. The client is assumed to be in error. (HTTP 400) (Request-ID: req-0b353680-6017-4baa-9f46-3935391480f8)

edit flag offensive delete link more

Comments

Read https://docs.openstack.org/python-ope..., especially the end.

By the way, when using sudo, most of your environment variables will be discarded. You don't need to be root to communicate with OpenStack.

Bernd Bausch gravatar imageBernd Bausch ( 2020-04-09 01:20:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2020-01-22 05:43:16 -0500

Seen: 1,132 times

Last updated: Jan 22