How do nova-cells really works?

asked 2014-02-27 13:18:28 -0500

JICarretero gravatar image

updated 2014-02-28 05:07:04 -0500

I'm trying to do some testing with nova-cells, however, whenever I try to deploy a new instance It goes to scheduling state and it never goes any further.

In one host (172.30.8.203) I've installed nova-api, nova-cells and nova-conductor: Binary Host Zone Status State Updated_At nova-conductor havana-novaController internal enabled :-) 2014-02-28 10:42:53 nova-cells havana-novaController internal enabled :-) 2014-02-28 10:42:54 nova-cert havana-novaController internal enabled :-) 2014-02-28 10:42:53

In another host (172.30.8.210) I've installed (appart from rabbitmq) nova-conductor havana-compute-1 internal enabled :-) 2014-02-28 10:45:35 nova-cert havana-compute-1 internal enabled :-) 2014-02-28 10:45:30 nova-scheduler havana-compute-1 internal enabled :-) 2014-02-28 10:45:35 nova-compute havana-compute-1 nova enabled :-) 2014-02-28 10:45:35 nova-cells havana-compute-1 internal enabled :-) 2014-02-28 10:45:28

I've defined the cells:

 Id  Name        Type    Username    Hostname         Port   VHost     
---  ----------  ------  ----------  ---------------  -----  ----------
  5  api         parent  guest       172.30.8.205     5672   None      
---  ----------  ------  ----------  ---------------  -----  ----------

And (yes, RabbitMQ is there for API).

 Id  Name        Type    Username    Hostname         Port   VHost     
---  ----------  ------  ----------  ---------------  -----  ----------
  5  api         parent  guest       172.30.8.205     5672   None      
---  ----------  ------  ----------  ---------------  -----  ----------

When I start the nova-cells services, I can see it connects to the other cell rabbitMQ for a moment, but it stays unconnected most of the time. (Is this the way it should work?)

I try to deploy a new instance and the API starNo error-logs are shown. The API queries glance for the image ID, neutron for the network id, everything goes well... But it stops. There's no communication between cells, no messages to AMQP, no error logs, nothing... but the instance goes to "BUILD/scheduling" state and it never moves to another state.

I've been trying to figure out how nova-cells works and understand how this should go forward, but the fact is that I haven't find anything helpful.

I'd like to find something more profound about nova-cells than the basic configurations I've found in order to understand this technology better.

So, any help would be very welcome.

Thank you in advance. José Ignacio.

edit retag flag offensive close merge delete

Comments

Very generic as a question, hard to give you pointers. Can you edit the question with more details, like log errors or other things that can help people give you an answer?

smaffulli ( 2014-02-27 13:58:42 -0500 )edit

Thank you smafulli, I've elaborated my question.

JICarretero ( 2014-02-28 05:09:05 -0500 )edit

Can you please supply the nova.conf for your API node and compute?

hillad ( 2014-03-01 13:58:20 -0500 )edit