Ask Your Question
0

A valid trait must be no longer than 255 characters, start with the prefix \"CUSTOM_\" and use following characters

asked 2020-01-01 10:25:12 -0500

jmora gravatar image

After adding the compute node to the stack, it looks like it is trying to create a new trait "COMPUTE_NODE" in placement but since it does not start with the prefix "CUSTOM_" it is throwing an error, at least to what it appears. Connecting to the api throws the same error when "CUSTOM_" is not prefixed to the trait name.

2020-01-01 10:11:54.873 108768 ERROR nova.compute.manager nova.exception.TraitCreationFailed: Failed to create trait COMPUTE_NODE: {"errors": [{"status": 400, "request_id": "req-3d0d8529-91aa-463c-92f0-c30c102aa414", "detail": "The server could not comply with the request since it is either malformed or otherwise incorrect.\n\n The trait is invalid. A valid trait must be no longer than 255 characters, start with the prefix \"CUSTOM_\" and use following characters: \"A\"-\"Z\", \"0\"-\"9\" and \"_\" ", "title": "Bad Request"}]}

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2020-01-02 04:53:28 -0500

cdent gravatar image

You need a newer version of the os-traits library installed where the placement service is running. COMPUTE_NODE was added as an official trait in October.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2020-01-01 10:25:12 -0500

Seen: 61 times

Last updated: Jan 02