Unable to set Continuous Update in Channel

asked 2019-12-10 11:08:06 -0500

Xitron gravatar image

I have 4 servers, and I've successfully set the Channel on 2 of them to Continuous Update. On the other 2 - identical VMs running identical software when built a couple of weeks ago - it fails when I try to do this. As soon as i click on "Set", I jump back to the previous screen, and it has a large red horizontal bar telling me, "Can not set channel! Wrong status." The only thing I see different is that on the 2 that fail, "Status:" is set to "Checking for new packages" while on the 2 that succeeded, it is set to, "Server is up to date".

Steps to reproduce:

  1. On Compute main screen, click on "Servers" in the left column.

  2. Click on the server.

  3. Click on Update on bottom right of screen.

  4. Click on "Channels' (currently set to "centos_7.7 (Current Release)", so select "centos7.x (Continuous Update)"

  5. Click on "Set'

Red bar of sadness will appear.

On the server in question, I've run:

yum check-update - Nothing available

yum upgrade - Nothing available rhn_check - Nothing new

I've checked for a running/stuck yum command, or rpm command, and neither appears to be running, causing the package update to freeze.

How can I get past this issue? Has anyone else had this issue?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-12-10 11:28:58 -0500

Xitron gravatar image

The apparent solution was to just schedule Next check [+] a few hours in the past. Dunno why it worked, but there you go.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2019-12-10 11:08:06 -0500

Seen: 22 times

Last updated: Dec 10 '19