'OSC_Config' object has no attribute 'load_auth_plugin' [closed]

asked 2019-12-09 22:46:53 -0600

Fixeeg gravatar image

I downloaded the shell commands from OpenStack Desktop and sourced them into my shell.

export OS_AUTH_URL=http://openstack.cs.school.edu:5000/v2.0
export OS_TENANT_ID=216b4b95aa9c4011aa27604342fa2ecc
export OS_TENANT_NAME="students"
export OS_PROJECT_NAME="students"
export OS_USERNAME="fixeeg"
echo "Please enter your OpenStack Password: "
read -sr OS_PASSWORD_INPUT
export OS_PASSWORD=$OS_PASSWORD_INPUT
export OS_REGION_NAME="RegionOne"
if [ -z "$OS_REGION_NAME" ]; then unset OS_REGION_NAME; fi

But then:

$ openstack server list
'OSC_Config' object has no attribute 'load_auth_plugin'

This is on MacOS and I just installed openstackclient with pip. Any help troubleshooting would be deeply appreciated!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Bernd Bausch
close date 2019-12-10 18:36:34.262747

Comments

1

I guess there is a version mismatch somewhere. Incorrect version of something needed by the openstack client.

For a start, I would try: Other openstack commands; the openstack command without any parameters (normally goes into interactive mode); the --debug option.

Bernd Bausch gravatar imageBernd Bausch ( 2019-12-10 03:32:36 -0600 )edit

load_auth_plugin should be in module openstackclient.common.client_config.

Bernd Bausch gravatar imageBernd Bausch ( 2019-12-10 03:36:56 -0600 )edit

Thanks Bernd; your hint was enough to lead me to a solution. I did pip freeze | xargs pip uninstall -y and then reinstalled with pip install openstackclient and everything worked. I had some issues with a library somewhere, evidently.

Fixeeg gravatar imageFixeeg ( 2019-12-10 13:12:47 -0600 )edit