Install all-in-one without internet

asked 2019-12-09 16:53:44 -0600

ARXC gravatar image

Hi, I'm trying to install OpenStack train in Centos 7.6 everything is fine until I execute the step packstack --allinone which in turn goes well until it reaches "Applying ip_controller.pp there it delays and returns the error: could not set 'present' on ensure: getaddrinfo: Name or service not know ... ... glance.pp line: 12" Can I escape that mistake? I install it in a vm without internet. Thank you very much in advance.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted

answered 2019-12-12 03:01:37 -0600

If you are installation without internet. You need to have local repo configure with all necessary package. you can download all packages manually put it into local FTP server. Configure yum accordingly. Then start installation Openstack.

edit flag offensive delete link more


That's fine, but what are those packages and dependencies? There's some guidance for this?... If I have internet but it is through a proxy, can I configure packstack to use the proxy?

ARXC gravatar imageARXC ( 2019-12-15 09:10:33 -0600 )edit

use below repo for latest release OS


or for offline mode

you can take package from

piyushsrivastava gravatar imagepiyushsrivastava ( 2019-12-16 01:17:03 -0600 )edit

answered 2019-12-14 08:42:52 -0600

m.m gravatar image

you need to mirror all these dependencies:

  • Python packages
  • Distribution specific packages
  • LXC container images
  • Source code repositories
  • GPGkeys for package validation

you can find more detailes in: (

edit flag offensive delete link more



This answer covers the OpenStack-Ansible deployment method. The question is about Packstack, which doesn't use containers and relies on Puppet rather than Ansible.

Bernd Bausch gravatar imageBernd Bausch ( 2019-12-14 21:39:12 -0600 )edit

What i said... I have internet... But through a proxy... How do I deploy with packstack?... You can't?... It's a shame it's so cumbersome. If I can add repos without problems configuring the variables http_proxy ftp_proxy and https_proxy the problem is in packstack... A pity.

ARXC gravatar imageARXC ( 2019-12-15 09:10:21 -0600 )edit

If you can access the internet via a proxy, I don't see why it should fail. Which name does the getaddrinfo message complain about?

Bernd Bausch gravatar imageBernd Bausch ( 2019-12-15 16:32:49 -0600 )edit

answered 2019-12-26 16:35:43 -0600

ARXC gravatar image

Hello, answering my own question, in fact there are no problems with installing through a proxy, you simply have to configure the variables in /etc/environment, example: export http_proxy = http://user:password@proxyip:port export https_proxy = http://user:password@proxyip:port export ftp_proxy = http://user:password@proxyip:port export no_proxy =, localhost, proxyip export HTTP_PROXY = http://user:password@proxyip:port export HTTPS_PROXY = http://user:password@proxyip:port export FTP_PROXY = http://user:password@proxyip:port export NO_PROXY =, localhost, proxyip. I hope it is useful to other colleagues, thank you all for your help.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2019-12-09 16:53:44 -0600

Seen: 471 times

Last updated: Dec 26 '19