Ask Your Question
0

Not able to set max connections in Mariadb for Openstack Stein Version

asked 2019-12-01 10:09:11 -0500

sona1990 gravatar image

updated 2019-12-01 10:54:17 -0500

Hi, I m using Openstack Stein version, I am facing an issue where i'm not able to set max connections for mariadb i have tried to set max connections parameters in "/etc/my.cnf.d/server.cnf" to 8048 but the changes doesn't reflects inside mariadb , still show only 594 max connections, looks like its not taking that parameter. I have used packstack for installing the openstack stein. Due to low max config i facing issues as after certain period the no. of connections gets full.

[root@brazilcontrollercompute0 ~(keystone_admin)]# my_print_defaults --mysqld |  grep "max_connections"
--max_connections=8048
[root@brazilcontrollercompute0 ~(keystone_admin)]#
[root@brazilcontrollercompute0 ~(keystone_admin)]# mysql -uroot -p***************
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 1802
Server version: 10.3.10-MariaDB MariaDB Server

Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]>  SHOW VARIABLES LIKE 'max_connections';
+-----------------+-------+
| Variable_name   | Value |
+-----------------+-------+
| max_connections | 594   |
+-----------------+-------+
1 row in set (0.001 sec)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-12-02 00:46:19 -0500

updated 2019-12-02 09:55:32 -0500

set max connection to 4096. and restart openstack service and mysql

it will start reflecting.

[root@ps_controller ~]# cat /etc/my.cnf.d/server.cnf | grep max_connection

max_connections = 4096

MariaDB [(none)]> SHOW VARIABLES LIKE 'max_connections'; +-----------------+-------+ | Variable_name | Value | +-----------------+-------+ | max_connections | 4096 |

Blockquote


login to mysql mysql MariaDB [(none)]> set global max_connections=4096;

edit on all controller node to make permanent /etc/my.cnf.d/galera.cnf

max_connections = 4096

edit flag offensive delete link more

Comments

Tried , it's still same

sona1990 gravatar imagesona1990 ( 2019-12-02 04:31:56 -0500 )edit

okay update it

piyushsrivastava gravatar imagepiyushsrivastava ( 2019-12-02 09:52:10 -0500 )edit

share you details above edited comment

piyushsrivastava gravatar imagepiyushsrivastava ( 2019-12-02 09:56:09 -0500 )edit

Tried that also still same and i have only one controller :(

sona1990 gravatar imagesona1990 ( 2019-12-02 12:05:38 -0500 )edit

once u updated mysql with set command

what is output after that. SHOW VARIABLES LIKE 'max_connections'; Its wired its not working for your environment

piyushsrivastava gravatar imagepiyushsrivastava ( 2019-12-02 13:03:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-12-01 10:09:11 -0500

Seen: 278 times

Last updated: Dec 02 '19