Ask Your Question
0

Ubuntu Bionic Server Image Creation Error on Microstack (Nginx)

asked 2019-11-25 11:39:40 -0500

paulrousseau gravatar image

I am trying to create an image in openstack using the ui and sourcing the bionic-server-cloudimg-amd64.img. However, the creation fails with error message:

<html> <head><title>413 Request Entity Too Large</title></head> <body bgcolor="white"> <center><h1>413 Request Entity Too Large</h1></center> <hr><center>nginx/1.13.0</center> </body> </html>

Is there a way to solve this problem ?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2020-02-09 00:51:45 -0500

BaseballDan gravatar image

The problem is that nginx is limiting the size of the file you're uploading. You can increase the size in the nginx.conf file.

sudo vi /var/snap/microstack/common/etc/nginx/snap/nginx.conf

In the http section, add the following line (I put mine after the types_has_max_size entry):

client_max_body_size 32768M;

That increases the maximum file size to 32GB. I started with 8192M (8GB) and hit the limit, so I went overboard in the interest of not having to do this again. After you've set it to your chosen size, restart with:

sudo snap restart microstack

That should resolve your problem. I realize this is a ways past your question, but perhaps it will help someone else.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2019-11-25 11:39:40 -0500

Seen: 590 times

Last updated: Nov 25 '19