Neutron linux bridge failing after restart

asked 2019-11-12 13:57:42 -0600

roadbl0ck gravatar image

updated 2019-11-12 21:13:54 -0600

Hi,

I have deployed OpenStack using Ansible All in one and github master branch

After deployment of the OpenStack I have created external network using flat and launched instance successfully. But the instance cannot able to ping outside world or I cannot able to ping to that instance.

I have added security group.

When I looked close I found that in /etc/neutron/plugins/ml2/linuxbridge_agent.ini physical_interface_mappings = vlan:br-vlan,flat:eth12

so I changed it to physical_interface_mappings = vlan:br-vlan,flat:eno1 (which is my physical network interface name)

and restart the neutron-linuxbridge-agent.service but after the restart I got error

20262 ERROR neutron.plugins.ml2.drivers.agent._common_agent [req-c271a970-60ae-4207-b98e-4dde3f4074e7 - - - - -] Error in agent loop. Devices info: {'current': set(['tap2d46acf2-b0', 'tapf37bc9fa-cf', 'tapb2e891f9-8d']), 'timestamps': {'tap2d46acf2-b0': 132, 'tapf37bc9fa-cf': 135, 'tapb2e891f9-8d': 134}, 'removed': set([]), 'added': set(['tap2d46acf2-b0', 'tapf37bc9fa-cf', 'tapb2e891f9-8d']), 'updated': set([])}: KeyError: 'gateway'

ERROR neutron.plugins.ml2.drivers.agent._common_agent physical_interface) ERROR neutron.plugins.ml2.drivers.agent._common_agent File "/openstack/venvs/neutron-20.1.0.dev31/lib/python2.7/site-packages/neutron/plugins/ml2/drivers/linuxbridge/agent/linuxbridge_neutron_agent.py", line 287, in ensure_flat_bridge ERROR neutron.plugins.ml2.drivers.agent._common_agent if self.ensure_bridge(bridge_name, physical_interface):

but the neutron-linuxbridge-agent.service is active and running. and also I tried to launch instance but it stuck for 5 mins at spawning state and failed

Nova compute service is active and running.

Can you please tell me where I am going wrong?

[Edit]

I can use any network interface like eth13 eno2, I wouldn't get any error but if I use eno1, I get error

Do you think it is a bridge issue? because I didn't create bridge

edit retag flag offensive close merge delete