Ask Your Question

Forcing mtu to 1400 via /etc/neutron/dnsmasq-neutron.conf per DanielS

asked 2014-02-25 13:35:49 -0500

dbaxps gravatar image

updated 2014-02-27 16:49:17 -0500

smaffulli gravatar image

Quoting Closed question

Edit the file: /etc/quantum/dhcp_agent.ini and set:
Create and edit file /etc/neutron/dnsmasq-neutron.conf and put this inside:
Restart DHCP:
service neutron-dhcp-agent restart
And reboot your instance. Verify that your MTU is 1400

Doesn't work for me on "Two Node (Controller+Compute) Neutron GRE+OVS+Gluster Cluster" on F20 boxes with Havana manually installed via native repos. Have to run ifconfig eth0 mtu 1400 up via /etc/rc.d/rc.local to set the MTU to 1400.

edit retag flag offensive close merge delete


what did not work ? This option did not work ? or service did not come up ?

dheeru gravatar imagedheeru ( 2014-02-25 20:43:01 -0500 )edit

No , service restarted fine. Option is ignored. If it would work it would make things with ssh connections to new instances much easier than I do it right now.

dbaxps gravatar imagedbaxps ( 2014-02-26 01:41:23 -0500 )edit

4 answers

Sort by ยป oldest newest most voted

answered 2014-02-28 06:33:03 -0500

foexle gravatar image


Kill DNSMASQ: killall dnsmasq

Restart DHCP: service neutron-dhcp-agent restart

Dnsmasq will not load new configuration without killing.

Cheers Heiko

edit flag offensive delete link more


I restarted box. So , dnsmasq processes restarted also with new config. It didn't help.

dbaxps gravatar imagedbaxps ( 2014-02-28 11:47:49 -0500 )edit

Which interface driver and dhcp driver you are using ? check in your dhcp agent config file

foexle gravatar imagefoexle ( 2014-03-07 03:41:18 -0500 )edit

[root@dallas1 neutron(keystone_admin)]$ cat dhcp_agent.ini | grep -v ^# |grep -v ^$
interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver
handle_internal_only_routers = TRUE
external_network_bridge = br-ex
ovs_use_veth = True
use_namespaces = True
dmasq_config_file = /etc/neutron/dnsmasq.conf
The last file was obviously updated

dbaxps gravatar imagedbaxps ( 2014-03-07 04:20:03 -0500 )edit

I'm missing you dhcp_driver, maybe it this a default option: dhcp_driver = neutron.agent.linux.dhcp.Dnsmasq In addition you're using veth interfaces ?! I don't know if this have an impact.

foexle gravatar imagefoexle ( 2014-03-07 04:43:31 -0500 )edit

answered 2015-04-28 06:33:55 -0500 gravatar image

I have correct setting without any typo, in icehouse, but still can not get it work.

nobody 5797 0.0 0.0 28208 2352 ? S 19:04 0:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap1aa4d9f7-fa --except-interface=lo --pid-file=/var/lib/neutron/dhcp/3bd17cd2-faca-4763-bfa8-7027b2b910d1/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/3bd17cd2-faca-4763-bfa8-7027b2b910d1/host --addn-hosts=/var/lib/neutron/dhcp/3bd17cd2-faca-4763-bfa8-7027b2b910d1/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/3bd17cd2-faca-4763-bfa8-7027b2b910d1/opts --leasefile-ro --dhcp-authoritative -- dhcp-range=set:tag0,,static,86400s --dhcp-lease-max=256 --conf-file=/etc/neutron/dnsmasq/dnsmasq-neutron.conf --domain=openstacklocal

had rebooted vm,dhcp-agent service, network/controller node, no help.

root@controller:/var/lib/neutron/dhcp# more /var/lib/neutron/dhcp/3bd17cd2-faca-4763-bfa8-7027b2b910d1/opts tag:tag0,option:router,

dhcp agent debug file does not has any dhcp option related info.

edit flag offensive delete link more

answered 2015-04-28 21:05:34 -0500 gravatar image

I found the dhcp work correctly, the dhcp offer and ack shows there is option26, the client does not support send out option26.

edit flag offensive delete link more

answered 2014-03-16 04:47:21 -0500

dbaxps gravatar image

Thanks a lot. It was just a typo in dhcp_agent.ini in line :- dnsmasq_config_file = /etc/neutron/dnsmasq.conf This typo clearly shows up in previous comment : dmasq_config_file = /etc/neutron/dnsmasq.conf <- wrong Last line from dnsmasq.log :- Mar 16 13:35:08 dnsmasq-dhcp[26111]: 1830014980 sent size: 2 option: 26 mtu 1454 Thank you once again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2014-02-25 13:35:49 -0500

Seen: 3,739 times

Last updated: Apr 28